Initialising VSTi with CC Automation

Project created using multi-timbral instance of HALion Sonic SE in C6.5. All tracks have volume, pan, reverb and chorus automation recorded on Automation tracks. Program Change information is stored in the “base” MIDI track.

Now need to audition the project on another instrument. In this case an external MotifXS (configured as a VSTi in the instrument rack).

Changing the outputs from the track inspector to the MotifXS, initialised in song mode, and hitting Play correctly selects voices (recorded as PC on the “base” MIDI track) but the initial CC values (recorded on the Automation tracks) are not sent to the instrument.

  1. Create a MIDI track and assign it to HALion Sonic SE
  2. Insert a Program Change on the track
  3. Record some automation (eg a Pan setting at the begining of the track)
  4. Ensure Read Automation is enabled
  5. Play the track
  6. Open the HALion Sonic SE editor and select the Mix tab. You’ll see the correct voice selection and the recorded Pan setting on the track.

This is all as it should be. Now:-

  1. Open the Instrument Rack
  2. Insert a new instrument (this is where I select the external MotifXS VSTi)
  3. Change the track output to this instrument using the track inspector
  4. Check that Read automation for the track is still selected (it should be)
  5. Rewind the project to the start and press play
  6. Open the VSTi instrument (eg the MotifXS VSTi editor). You’ll see the correct voice has been selected but NOT the recorded Pan automation setting

I have discovered two workarounds:-

A) Create a new event on the automation track by clicking with the pencil tool. Then delete it. All recorded automation for that track is now sent to the instrument.


B) From the MIDI menu select “Configure CC Automation”. When the window opens, change any option value and then change it back. Close the window. All initial automation is sent to all tracks for all VSTi instruments.

My expectation is that when switching VSTi instrument initial automation values would be sent from the automation tracks. For some reason this is not happening - can someone with more understanding of C6.5 tell me whether I’m doing something wrong or some if there is some preference I need to set to make things happen in the way I expect?


BTW If I don’t use automation tracks and record CCs directly on the “base” MIDI tracks everything works as I’d expect - the CC changes are initialised on the swapped VSTi as soon as I hit Play.

Yep - had recreatable similar symptoms with instrument volume setting in HalionSonic. Unless I started the track at the beginning every time, I would have zero volume, rather than what the instrument/channel setting was.

For me, the solution was just one of adding a single volume change event in the channel automation, and it seems to ‘chase’ automatically.

Is this scenario consistent with your experience?

Maybe the Pan CC of the Motif is not the same CC Number as the one of HSSE.

Usually Panning should be cc#10. Maybe the Motif has it set to another number.

If there is automation data on the track after the start, then, as you say, this is sent to the instrument. The problem seems to be that if there is only one CC event on the automation track at the beginning of the project this is NOT sent to the connected instruments.

I always have one bar of “set-up” at the beginning of a project. It has no note events, it’s used entirely for setting up the CCs and PCs for each track. However, whilst the PCs are actioned (they are stored as events in the “base track”) any CCs recorded to the automation tracks are NOT sent.

No, it is not a problem of MIDI implementation on different instruments. The CCs are sent when you provoke C6.5 into doing it and they have the expected effect on the connected instrument.

The problem seems to be that C6.5 does NOT SEND the first CCs recorded on the automation tracks when you hit play at the beginning of the project.

Has anyone else been able to replicate this issue?


Go to the Preferences and activate “follow notes”.

Thanks for your responses but I can find no such preference. Where is it?
Perhaps you mean “Automation Follows Events”. If that’s so, then this is an option for editing parts. It has no relevance to automation tracks sending their data at the start of a project when play is clicked.

Yeah, that’s it. You’re right. When you enable that button Cubase will
first look for Keyswitches or other controller data that affect the note when
you hit play at a position where it usually wouldn’t take effect anymore.
So I thought that this could maybe help.

Maybe you should open a support ticket. Could be a bug (maybe).

Good luck!

Best regards.