Initializing tracks on playback

Hello, I’m new to Cubase 5 and am having difficulty trying to do a basic thing using midi tracks.
After selecting a patch for a track, I find that the patch selection is not recalled during playback, ie. if I restart my midi device, whatever instrument powers up at default is the one used for playback even though I have selected a different patch for that track.

My simple setup is a clavinova cvp509 USB’d to a PC. Thanks for any help you can give.

Because there’s a program change at the beginning of the MIDI file that needs to be deleted.

mashedmitten, thanks for the quick reply.
I’ve viewed all tracks using the list editor. I do not see any program change control data. To further convince myself, I inserted a program change in the track. That works great but I still cannot get it to start playback with the patch selection in the track pane.

Are these downloaded files? Is there a master track associated with them?

No, it’s as simple as can be. I started cubase, opened a new project (used some template that gave me all 16 channels on a track each), setup my midi devices and started recording.

Ah, there have been issues with Templates. Try it with a new blank project and set things up yourself and give it a go.

Just tried it. Selected ‘Empty’ when asked which template I’d like to use. Quick check shows same problem. :frowning:

Which VSTi are you using? There’s a Pref under MIDI to reset on stop, see if that affects it. Screenshot of project page and List Editor? What are the MIDI Filters set to, should be only Sysex.

Reset on stop didn’t work.
I’ve attached the #1-project page #2-list editor #3-preferences-midi #4-midifilter #5-midifile (see next msg for #4,#5)
I must admit I don’t quite know what the midifilter does so let me know if you spot something. Thanks for helping out. I appreciate it.
midipref.gif
projectpage.gif
listeditor.gif

Attaching midi filter and midi file settings.
midifile.gif
midifilter.gif

CVP509, is that your MIDI device? If you’re using the sounds from it, you have to set up an audio track to monitor it.

Yes, the cvp509 is the digital piano I’m getting the sounds from. It has it’s own speakers and audio recorder so I don’t think I need to monitor it from Cubase.

Then it’s a setting on the keyboard itself, nothing to do with Cubase. Does the patch name on it change when Cubase’s does? Do you have it set up as an External Instrument using a Device Map to control it from Cubase?

Yes, the patch on the digital piano changes when I change the patch names on cubase. So I know it is responding to program change and bank select messages from cubase. The problem seems to be cubase NOT sending these out at the beginning of playback. In sonar there is a ‘search for controller/patch before playback’ feature but I can’t find it on cubase. Or maybe it doesn’t have one.

I’ve attached my midi device manager and device setup for your reference.
mididevice.gif

What I’m asking is if the patch on the keyboard changes from what’s selected in Cubase when the wrong patch plays. In MIDI Chase, there’s a box for program change. Does un-checking it make a difference? Did you try putting a program change at the beginning of the file in Cubase?

  1. The patch on the keyboard does not change when the wrong patch plays. I don’t think it received any patch change request from Cubase.

  2. If I manually insert a program change in the track at the beginning, that works fine.

  3. The Midi Chase - program change entry does not make a difference. It was initially unchecked. I checked it to see if it helped. It did not.

Looks like 2 is the answer until you sus out why the keyboard is changing the patch.

I upgraded from cubase 5.0 to 5.5 and this fixed the problem. Thanks for helping, mashedmitten.