Input Drums with MIDI Keyboard via live recording

I select the drums staff, click on record, start playing on the midi keyboard but once I stop the recording I can’t see any note on the drums staff…

Am I doing something wrong?

I’m using percussion map input mode
I’ve set an external VST for Drums

While recording I can properly hear what I’m playing…

The recording lasts 24 bars in 3/4

During the recording I keep playing just one note (I’m trying to write Hi-Hat part)

I’m not sure what might be going wrong, Jack. In general this works in the way that you would expect. Are you able to record onto a pitched instrument with no problems?

actually yes, I can record all the other pitched instruments…

The project is a quartet loaded with external vst: Guitar, Piano, Bass, Drums

I found that in a brand new project I can record drums as expected, but only if I’m using HALion Sonic SE…once I load an external vst such as Addictive Drums in my case, I can’t no longer get drums recorded, even if I switch back to Halion Sonic…

You might need to check that you have the appropriate percussion map chosen in the Endpoint Setup dialog so that Dorico knows how the MIDI notes on your keyboard correspond to the patch you’re using.

I’ve just tried a couple of times to load a new quartet project with HALion Sonic SE only…but now it won’t record anything…

I’ve checked and I’m using the same percussion map (General Midi)

Now I tried to load again an external midi and Dorico Freezed I had to force quit… I might need to reinstall dorico

last update: I loaded “Jazz quartet” template… I’ve been able to record some piano, then nothing else

You might be running into the problem that some users have experienced where MIDI input simply stops working after a while: you can still hear notes being echoed back to you, but nothing goes into the score. If a fix for this is coming soon, in the next Dorico update. In the meantime, quitting and restarting Dorico should be sufficient to get you back up and running again.

…I restarted Dorico several times, but no luck, starts working and then stops…I hope for the update…in the meanwhile I’ll try to reinstall it again, I also noticed some out of sync audio and random midi notes in the playback when using external vst’s…or the open symbol on durms hi-hat being ignored, grace notes ignored…etc…something is really gone wrong LOL

Few days ago I have experienced the same problem, but while recording piano real-time. The recording started normally, with click and red cursor
but when stopped it, nothing appeared nor score sheet, nor in Play Mode.
Then I restarted Dorico and the problem was fixed. I suppose it is related to connection between Dorico and the Audio Engine?!

Best regards,

Maybe, who knows?