Input Transformer acts unexpected

Hi
I want to be able to use a small Akai Pad Controller (LPD8) to generate CC1 controller to generate key switches to use with a VSL Flute.
The VSL system is complicated! Every KS can be altered with 4 values of CC1 so instead of having 12 KS in an octave, it’s possible to have 4*12=48 KS. And it’s needed to, the Flute patch has 27 KS!
The first patch is staccato, and if you turn the mod wheel (CC1) you can choose additional 3 patches.

I thought of using the Input Transformer to convert pad 1 (C-2 to CC1/10), pad 2 (C#-2 to CC1/50), pad 3 (D-2 to CC1/85) and pad 4 (D#-2 to CC1/110). So I could just press my normal KS (C1) and then hit pad 2 to select the 2. patch.

So here is the situation to be tested:
Start a new empty project in Cubase Pro 8 (I’m on 8.0.5 build 418 on Mac.)
Create a midi track.
Click on Input Transformer - local.
Transformer window opens.
Add the following data in Module 1:
Skærmbillede 2015-02-12 16.10.46.png
Notice that although Controller is selected in the first Action Target line, the corresponding parameter is a note name (C#-2)!
Now try to make a second Module like this:
Skærmbillede 2015-02-12 16.07.33.png
And here is the 3.rd Module and almost every data type is now wrong - and it doesn’t work either:
Skærmbillede 2015-02-12 16.12.34.png
The Module 1 & 2 works but Module 3 generates not the wanted CC1/110 but CC110/99!
During the building process Cubase 8 crashed several times.
Regards Musicmind

But module 3 has two action lines set to Value 1.

(Well spotted, Steve! :slight_smile:… and aren’t the first two screenshots inverted anyways?.. makes it a bit difficult to follow what is going wrong where :wink: )
As regards the CC#s displaying as note values, go into Preferences>Event Display>Chords (don’t ask why! :stuck_out_tongue: )>Pitch Notation>Naming Format, and set it to “MIDI + MIDI Note Number”.
At least, while it will still show note names for those CC#s, it will now at least show also their CC# number, e.g. “C#-2/1”, “D-2/2” etc.

Hi
Sorry about the 2 times value 1!
And thanks a lot for the tip.
It seems to work now!
BUT!!! Still one bug left, because when I hit play with an empty midi track selected and tap my Akai controller and then hit SHIT+* to capture the recording Cubase crashes! So no checking the controller set-up with the capture recording facility.