Input Transformer: Play drums using a footswitch


How is this possible, please?

The Input Transformer allows you to Convert a controller like a foot pedal into MIDI notes (for playing bass drum the right way). ( manual, page 673)

Any help would be greatly appreciated.


(not sure which manual you are looking at, but that isn’t what pg. 673 gives me here… wait a minute… are you referring to the printed manual… haven’t seen one of those in years! :stuck_out_tongue:)…
Anyways, what isn’t it explaining? If you are referring to, for example, the sustain pedal, which, by default transmits CC#64 with a value of either 127 (for “on”) or zero (for “off”), then the Input Transformer can convert that into any one note data (the Input Transformer’s “Value 1” means the Controller number, or the Note number, while “Value 2” is the value of that controller, or, in the case of a note… its velocity (where “zero” means “note off”).
So if you merely change “Type” from controller" to “Note”, then the sustain pedal will play E above middle C (MIDI note number #64). If you wanted it to play middle C, then you would chenge the Action in the lower section of the Input Transformer to “Value 1___set to fixed value___60”.

Thank you vic_franc for the response. With you help I could get the first to change controller type to note the and it works. But it sounds the percussion 'Conga".

The track that I am recording is set to channel 10. I was wondering how I could play kick drum ( C0) with it. Attached please find my screen shot of my settings.


Thanks again,


Because your sustain pedal is transmitting “64” as its “value 1”, when you convert that into a note, via the Input Transformer, that means that MIDI Note #64 (i.e.E3) is triggering the conga. So you then need to covert that “Value 1” into C0 (which is MIDI Note# 24)

So you just need to add a line in the lower section of the Input Transformer (immediately after your “Type__Set to fixed value___Note” line)…

Value 1___Set to fixed value___24 (don’t worry, it might still look like it is a controller… little GUI bug in Cubase :wink: )

That should do it :wink:.

When I choose 24, it sets it to CC25 ( control 24) and it does not sound like bass drum. I tried different drum kits.

But CC24 plays metronome which is even better for my purpose ( real-time gradual tempo change. Now I can move on with my next milestone on the endeavor.

It seems very unstable and as you said its a GUI bug. Changing parameter 1 for value 1 made Cubase disconnected from my keyboard and at the end froze and had to restart cubase!

Thank you.

Could you post a screenshot of how you set up the Input Transformer, please? I really don’t see what could possibly make the Input Transformer cause a freeze.
[EDIT: One possibility… I see that you have your MIDI track set to “All MIDI Inputs”. Maybe the instrument that is playing your drums is re-transmitting the MIDI data, thus sending into the mix of “All MIDI Inputs”, therefore causing a MIDI Loop. Change the Input of that track from “All MIDI Inputs” to that of your Yamaha.
Anyways, the Input Transformer should look like this…

That is exactly what I had. Now it is fixed.

Thank you for the screenshot:)

(Tell me about it! lol… I have had nothing but computer (and internet) flukes all day… even just now I had to reboot… there are just days like that, I suppose :wink:. ) Anyways, glad you got it sorted out :slight_smile: