Input Transformer

I try to setup Input Tranformer to transform keyvelocity of a certain key to aftertouch, but didn’t manage yet.
( I need this for a certain plugin, Sonokinetic Hurdy Gurdy for Kontakt 5. My problem is playing the rhythmic trompette sound which is triggered by aftertouch. I prefer to play this tone on a key, in my example A0)
I attached a screenshot of my Input Transformer configuration.
Now when I press A0 while recording, there appear only aftertouch values of 33. And when I release the key, the aftertouch value remains 33.
Maybe someone knows a solution for this? I would be very thankful!
Cubase Input Transformer Hurdy Gurdy.jpg

Hi,

I’m afraid, this will not work in the Transformer, because there is no “Insert” option.

But you can use MIDI Insert Transformer. Set it like this:
Type Is > Equal > Note > And
Pitch > Equal > A0

Type > Set to Fixed value > Aftertouch

Function: Insert

Then, don’t forget to press the Record Output to Track button in the track. Now, every single A0 Note will add AfterTouch message with the same value, as the Volume of the MIDI Note is.

Is this, what you want to?
Screen Shot 2015-08-07 at 1.07.50.png

Thanks Martin for your response!
I set up the MIDI Input Transformer exactly like you explained.
Now every keypress A0 creates an Aftertouch value of 33, but after key release it keeps that value. Unfortunately it is not usable this way; the Aftertouch value should go back to zero.
The note values also are recorded in Insert mode; I don’t need these though.
Is it possible to transform the velocity values of A0 to aftertouch values?

Hi,

Yes, in the upper area set: Value 1 > Morethan > 0.

In this case, the MIDI Note Off message will be ignored.

If you want to send an AfterTouch 0 when Note Off comes, insert another one Transformer and set it:
Type Is > Equal > Note > And
Pitch > Equal > A0 > And
Value 1 > Equal 0

Type > set to fixed Value > AfterTouch
Value 1 > Equal > 0

Value 1 changes to Pitch again. Do you mean Value 2? That changes to Velocity.
There is no Condition “Morethan”, I assume you mean “Bigger”?
All recorded Aftertouch values are again 33 though.

Again here do you mean Value 2 instead of Value 1?
In the upper field, Value 1 changes to Pitch and Value 2 to Velocity.
In de lower field, for Value 1 there is not an operation “Equal”, do you mean “Set to fixed value”?
When I make the parameter 0, it is changing to note C-2.
For Value 2 I can “Set to fixed value” to parameter 0.
Though still I get the same result, all aftertouch values stay 33.

Now I tried in the second Transformer in the upper field Value 3, which changes to “Off Velocity”, then Condition “Bigger” and Parameter 0. like:
Type Is > Equal > Note > And
Pitch > Equal > A0
Off Velocity > Bigger > 0

Type > Set to fixed value > Aftertouch
Value 2 > Set to fixed value > 0

Unfortunately I still get the same result. I feel it should it be possible but still can’t manage.
In the attachment a screenshot of my two Transformers.
Cubase Input Transformers 2x.jpg

I’m sorry, I wasn’t in the studio, when I posted the previous message. And I did some mistakes there.

So, this is the correct one, which will work for Note On only (and Note Out is filtered, so it will be not reseted - do you want to reset it?).

Type is > Equal > Note > And
Pitch > Equal > A0 > And
Value 3 (Off Velocity) > Equal > 0

Type > Set to Fixed Value > AfterTouch

Function: Insert
Screen Shot 2015-08-07 at 11.06.23.png

Thanks again Martin for the answer!
Unfortunately this still gives the same result: all Aftertouch values are 33 and stay on that value.
(I wonder from where comes that value 33?)
After A0 note off the Aftertouch value should go back to zero though.

Hi,

Could you insert MIDI Monitor MIDI Insert, please? Then Press and release the A0 MIDI Note. Ten make a screenshot of the MIDI Monitor plug-in. I would like to see, which data does your Cubase receive exactly, from the MIDI device. Then we could “tune” the Transformer for you, hopefuly.

(Hi Martin,
I’ve just been messing around with this myself, and I am beginning to think there may be a bug here… what I am seeing is that, when the incoming MIDI has velocity of zero (i.e; note off), it does get converted into aftertouch, but with the value it previously had (i.e; the value of that original note’s note-on velocity… might be why the OP is getting that value of 33, if that is what his note-on was originally)

Btw, what I think should be the correct Transformer setting is…

Upper section…
Type is___ Equal___Note___And
Value 1 (Pitch)___Equal___A0(/21)

Lower section…
Value 1__Use Value 2 (the aftertouch will eventually read Value 1, which, via this line, will now be the value of the velocity of the incoming note… including “zero” when note is released)
Type__Set to Fixed Value___Aftertouch

Here, that all works, except that upon releasing the note, the transformed aftertouch has the previous value. (N.B This is not the value of any “real” note-off data i might be transmitting)

Just out of interest, if I convert note-ons (and offs) into CC#1, it works perfectly, given that upon note release, the transformed CC#1 gets the value of my “real” note offs (my own keyboards do indeed generate “real” note off data).

Hi,

To be honest, I also think, there is a bug. The MIDI Note Off shouldn’t pass thru, when I exclude it from the condition by using Value 2 - biggest then - 1.

Yes, that makes sense :wink:. So, do you think there is one bug, or two? (difficult to formulate, if the Steinberg developers want to track it down :wink: )

I would say one bug. If it doesn’t help after the fix, lets enter another one. :wink:

Sounds like a plan :wink:

Thanks Martin and Vic for your patience and trying to help!



In the attachment I put the screenshot of the MIDI monitor. Here I followed Vic’s transformer setting, which transforms the right note-on velocities, but repeats this value on note-off.

Indeed I get the same result. The very interesting thing now is that when I use Input Transformer instead of MIDI insert Transformer, with the very same configuration CC#1 DOES go back to zero after note release. Aftertouch unfortunately doesn’t: note-off gives the same value as as note-on.
Despite of the supposed bug, could there be a workaround? For example, a second Transformer which turns note-off to an Aftertouch of zero?
Cubase MIDI Monitor.jpg

I’ve been scratching my head about this one too, but unfortunately we cannot choose a note-off as an action target. Maybe after a night’s sleep… btw my real name is Rip Van Winkle :stuck_out_tongue:

Hi,

Interesting, you also have the Value 3 = 0 for Note On. This is the reason, why I used "Value 3 > Equal > 0, in my condition. This one filtered out Note Off, and they were ignored, thanks to this.

Btw: Rip is right, for the AfterTouch Value, you have to take Value 2 of the MIDI Note, not Value 1.

:laughing: Just woke up in time to see that :wink:

Well my only workaround for the moment is to use an external hardware device:
my little old MIDI Solutions Event Processor Plus does the job.
Thanks so far for the help!
Of course it’s more handy and elegant to use Cubase for this, so if by chance you guys still come to another idea, I would be glad to hear!
Should we make an issue report to attend Steinberg of this possible bug?