Insane GUI Lag

This is a problem that i’ve had for some time now, and i can’t seem to fix it.
I’ve googled my ass off to no avail.

This is a project with no instruments, audio tracks or FX.
VEP isn’t connected. It’s pure midi data.

I uploaded a clip of the problem to dropbox:
https://www.dropbox.com/s/q4t7959wywf0i2w/Desktop 2018.06.25 - 16.25.21.02.mp4?dl=0

At the laggiest part in the video, there’s 17 different midi tracks being triggered, and most of them has from 1 to max 4 types of CC data written in them (Vel, Mod, exp, pitch or cc16).

I have a GTX 1080, and i’m running cubase in 3440x1440p.

I’ve already tried:

  • Reinstalling Cubase (had this issue in Cubase 9.0.4 and it’s no better in v9.5)
  • Reinstalling Audio interface drivers + software.
  • Reinstalling GPU drivers (Also tried rolling back to earlier versions)
  • I must have tried to check/uncheck every single option in the cubase preferences by now.
  • Disabled all kinds of stuff like Windows Defender.
  • Cleaned up PC with CCleaner etc.

I’m out of ideas now.

It’s extremely frustrating to work like this.
If it can’t handle 17 midi tracks not connected to any instruments, how is it gonna perform with twice that amount?

Any ideas what else can i try?

Thanks.

1st post… Welcome! :slight_smile:

I have no idea if this will work for you but, a while back I had a similar issue…

I fixed it by doing the following:

  • I uninstalled the graphics driver from my Mobo (maybe you could just disable it in the bios?).
  • My Mobo had two Realtek audio drivers installed. I uninstalled the “HD” one and use the other for PC related sounds.
  • I did a clean install of the latest nVidia graphic driver only. I did that by choosing “clean install” and “custom” and I “unclicked” all of the other software that gets installed with the graphics driver. Don’t forget to scroll down a bit to unclick everything in that list.

If running Win 10… I recently installed the latest Mobo bios. That seemed to make Cubase work even better. So check if one is available for you from your Mobo mfg site.

Good luck :wink:

Regards :sunglasses:

None of that helped unfortunately, but thanks.

Maybe i’m wrong but this problem goes to your HDD
Check disk load in VST performance meter and also in disk load Windows Task manager when lag is active

Steinberg Cubase 11 has Laggy GUI Graphic Problem on both Intel & AMD GPU
I am on Windows 20H2

i tried on Aorus GTX1080ti , RX 5700 XT 50th & RX570 three GPU
Studio One 5 was no problem on both GPU.

  • I tried few Drivers installed using DDU tools via Safe mode
  • Disabled HDMI Audio Driver
  • Disabled all kinds of stuff like Windows Defender.
  • Turned Off Asio guard, on both device & plugin manager
  • GeForce control panel set to Performance Mode
  • Tried all resolution

I’m out of ideas now.

Steinberg must fix this…or maybe Vienna Ensemble Pro?

I included video here

https://youtu.be/p7iwZFC2ayM

Try checking your plugins. Sometimes a faulty plugin can cause the entire Cubase GUI to be extremely sluggish. Happened to me before.

1 Like

On this video I used just Cubase & Vienna Ensemble Pro.

Hi, I had this same issue with MacOS, and while I can’t guarantee it’ll be the same with your system, the cause of mine was too many VE Pro Ports per instance.

Try with cubase 10.5 also try with hdpi on or off, make sure your power scheme/saving is set as recommended (both in windows and bios) also try without vienna. I see that you are using 4k display? try on some smaller for ex:1080p single setup screen to pinpoint the problem.