Insert (I) bit me again

It’s too easy to unknowingly enable the Insert (I), considering the disastrous consequences that can befall my score as a result. An inner voice gets inadvertently moved rightward again and again.
Please please post a warning dialog before allowing me to proceed destroying hours of work. For those who never make mistakes, you could include a “Don’t ask again” checkbox.

1 Like

Question: how does the inadvertent activation of Insert mode happen to you? If it is by pressing the short key (which I presume), then you can just remove that short key assignation in Preferences.

I find, that the different appearance of the caret and the light of the Insert mode button are enough to notice, that you are in insert mode.
In a program like Word you don’t get a special warning, when you engage insert mode as well.
I would find it annoying, when I would get a warning every time I engage insert mode.
It’s more or less a question of getting used to the software.

The toolbar on the left has a symbol that means Insert. Typing the letter ‘I’ (eye) causes everything in the voice to shift one note to the right every time you type it. I want to undo that. Since it happened hours ago, all the work I did since then would have to be undone and redone unless there were a way to shift all the notes in the 2nd voice back to their proper position. I did it once, but I can’t remember how I did it.

The Insert symbol lights up when you type “I”. I noticed it was lit and found the 2nd voice shifted rightward since I don’t know when.

1 Like

To HelPet: That’s why there are “Don’t ask again” checkboxes in many dialogs. That’s what I suggested in my original post for those who never make mistakes.

To Alexander: I don’t know what the “short key” is.

Spencered, for moving the notes in a particular voice back, you can select them (either directly or by selecting a larger range and filtering for the appropriate voice) then in Write mode using Alt-Left arrow to move the selection back by increments according to the rhythmic grid. Hopefully this helps for your current situation at least.

2 Likes

I will preserve forever this invaluable message so I never have to struggle with this again. That and another from a different thread suggesting I disable the key command ‘I’ for inserting. Thanks, guys!

You can also select notes or rests before the inserted notes with insert mode on. They will be pulled backwards again.

Unfortunately, it’s not always the case that you are inputting notes whilst the Insert caret is active; it’s very common to paste something with no visual clue that you are shoving something along inadvertently several page up, with disastrous consequences for your later workflow.

This is a dangerous tool and I don’t think I’m alone in wishing that it behaved more like Lock Duration: when you esc. input, it should exit Insert mode (for me).

I too have been bitten more times than I can count.

3 Likes

So what would you suggest? A (near) screen-wide bold face semi-transparent watermark that says “Insert On” or something along those lines, activated (or not) in the Program Preferences?

(I am not being facetious, just suggesting an option that would be very clear for those who wanted a warning but would allow users to see and work with the notation beneath the warning. Personally, I’m not sure I would use it.)

Well, for me, as I said: Insert could exit once you’ve escaped the input caret. And for pasting, and option to paste as an insert because, for me, this is where the real danger lies.

Having said that, I’m well aware this is an issue that has a history on one side or another!

Then you’d need another option for deleting passages within Insert mode.

Hmm, yes I suppose you would (never thought you do that operation)

I’ve had similar problems, you are not alone.
Perhaps the caret could blink (like in word processor), when Insert is active.

Insert mode does already give you chevrons at the top and bottom of the caret.

1 Like

I guess i sometimes suffer from an acute case of chevron-blindness…

I try not to use insert mode at all any more because of this. I always forget to turn it off and it takes a lot of tome to fix the damage.

Me too. The risk/reward ratio makes it virtually unusable for me. I would love a feature that limited it to the current bar. As I’m presumably looking at the bar I’m editing, I can catch any deleted notes. When insert affects something not even visible on screen, it’s way too easy to not even realize anything has been changed until it’s way too late to Ctrl-Z fix it.

FWIW, Finale’s insert feature not only is limited to the current bar, it allows you to overfill the bar until you try to leave the editing window. (It does then present the option to keep moving the notes until all measures contain the correct beats too.) This is great for inserting and changing a rhythm to be non-destructive. The overfill feature goes completely against the Dorico grid concept, so I know there’s no way that would come to Dorico (nor would I necessarily want it to), but limiting it to a single bar would make it usable again for me as I could quickly catch any mistake or simply re-enter the incorrect music.

I understand many people might not want the insert functionality to change, but it would be great if there was a user selectable preference to limit any Insert edits to the current bar. Unmetered inserts could remain unaffected by this.