Insert mode doesn't move grace notes in open meter

Hi!

I love being able to write open meter music without all the workarounds of other software, it really allows me to be more flexible in my composition process. However, I have hit a bit of a bump as I often want to change the duration of a specific note. Using Insert mode, the normal notes are moved, but not the grace notes and barlines that I have already entered.

As I’m currently writing a solo piece it makes sense for a barline to move with the rest of the music, their function as delimiters is in regard to the notes before and after them, not in regards to the number of beats into the flow.

Is there any workaround at the moment? Barlines can easily be put in last, but grace notes are an integral part of the music.

Cheers,
Erik

I’ve just given it a go and it seems to only be an issue if you edit the note directly before the grace note (with insert mode on). I’ll pass this on to the dev team, thank you.

You are correct, I spoke too soon, it’s only the grace note right after the prolonged note that doesn’t move. Thanks!

I just noticed that the dynamics also stay at their beat location instead of following the music when using insert mode. Is there an option for this that I haven’t found?

Partial workaround for the barlines if anyone is interested:
If you need to remove some time/beats somewhere in a flow, make them into a bar by placing barlines before and after. Then hit CTRL+B (on Win) and write -1 ENTER. Then remove the barline left behind if you don’t want it. This also keeps the dynamics at their correct positions.

Dynamics don’t move because they are not by default in the same voice as the notes you’re moving around. In due course we will add further options for Insert mode to determine whether you are inserting time only into the current voice, into all voices on the current instrument, or indeed on all instruments.

I eagerly look forward to that feature, sounds like a great tool for when you’re composing “in the box”.