Inspector 'Pin' not working for Instrument Tracks

Actually the forum is the best place to solve these tiny issues.
Contacting support should be the last resort.

How are you helping? In my experience I got replies within 24 hours. There’s also phone support.

I can confirm this.

When reporting a problem a repro works best, to make sure that the people who check your problem to the exact same thing you did to reproduce. I will bet that that didn’t happen here– I mean that people tried stuff, but not the exact thing the OP did.

Here’s a Repro:

  1. Create an Instrument track and load a VSTi on it.
  2. Click on the Instrument Tab
  3. Right-click on one of the tabs that appeared and select Setup…(I used the Audio Fader tab)
  4. In the dialog that opens click in the pin column for the items you want to pin
  5. Hit okay

Here none of the tabs get pinned.

In terms of support response times and ways to contact , it depends on where you are in the world. The US has a separate support team from the EU countries, and there a many countries in the world where Yamaha/Steinberg do not have official support, and people are referred to some local support which might be a retailer.

EU folks can call SB direct, in the US you cannot. in the US as well.

So for someone in countries without Steinberg or Yamaha Cubase tech support, the forum really is the best way to get answers.

If you have an problem or or a feature request sending it to the tech support team i not a bad idea. Especially since those communications are logged, whereas the forum is a more casual affair.

Apologies for the late reply.

Thanks for checking and confirming that Steve, I’ll drop Steinberg a line.

Can confirm, pins don’t work for instrument tracks…
Recently bought Cubase 10 Pro and keep running into small irritations like this one ever since.

Did you get a reply from the support team?

I received a reply a few weeks later, which answered a completely different question. So I gave up.

This is STILL an issue on Cubase 10!!!
Works on audio but NOT on INST or MIDI tracks.

The answer given it to hold ‘ctrl’ to have it work as a pin but imo that’s not a feature. It’s a broken feature and an issue that should be fixed.
4 years running? c’mon …

Update…Cubase 11 and it STILL exists.

May 2021, Cubase 11.0.20 and this is still not fixed. AMAZING!

1 Like

12.0.2…Still
:disappointed:

I agree the issue is only for the instrument part of the inspector.
This applies for either of Instrument Tracks, Sampler Tracks and Midi Tracks.
I have just added it to the Issues list.

instrument inspector

1 Like

I think this must have been not added due to some programmatical barrier, i.e., something else must be changed to do it, and changing that something would break something else, and changing that would break something else which would need to be fixed, etc.

Anywho, Same repro as in 2016.

2 Likes

Still not fixed in 12.0.30. :thinking:

Pinning on Instrument tracks is still an issue since Cubase 8.
In the inspector when pinning e.g. the inserts tab of the instrument, it doesn’t stay in this state when opening e.g. the send tab.
Also when strg+clicking all tabs to be open, if you click on one of them, all get collapsed.
It works for audio but not for instrument track types. Such an annoying bug.

Bump! This is still open.

So this is the answer from the support :

The Pin functionality was not developed for instrument tracks , it only concerns audio tracks.

The answer itself is confuse, the problem isn’t about the Instrument Tracks as a whole, but the instrument tabs (the tabs related to the audio part of the instrument, that are in fact the same tabs that we can find on Audio Tracks and on which the Pin is working fine…).
Whatever.

We have the Settings panel available, the pin column is visible, we are able to enable pin on selected tabs, click apply, but then it does not work because the few lines of code needed to close the loop are simply missing.
Is that really a technical barrier or some cult of laziness ?
To me this is clearly an unfinished feature that has been abandoned.

The first post in this Topic is from six years ago.
Come one Steinberg, you can’t tell me that during all that time you didn’t find a moment to “develop” the Pin for instrument tabs.

1 Like

Absolutely agree. The functionality is there, but it does not work/is buggy.

Saying it was not developed for instrument tracks is just not true. Obviously it was developed, because its there, but does not work. It is clearly a bug.

And the thing is, the solution is already there. The code already works for other track types. Just copy it over there, check if it works and move on. There is nothing really which has to be recoded.

EDIT: Also it would not make sense to have pinned tabs for all kind of tracks, but not instrument tracks, why the hell?
I strongly hope they are not just removing the feature and call that a fix “because it was not intended in the first place to be there”, that would most probably be more work than just fixing it properly.

Also: Thats my problem with most “inconsistencies” I encountered with Cubase. You often get the answer that “it was (not) intended to work like this” from Support or Devs even if other similar operations work in a completely different and much easier and objectively better way. To me these are not feature requests as they would say (like it would be the case here) but more like half baked features and therefore issues.

1 Like

We are aware of this. I posted some more background information last year:

3 Likes

Hi Matthias, thanks for the input.
Now I understand that the problem is in fact related the nested section – tabs in a tab – and the coding may not be easy.
I’ll give a quick update on the topic you just shared :wink:

Thanks for the response, although the whole thing does sum up the frustrating way Steinberg operates.

Why advertise this as a feature to begin with, when it was known not to have worked properly before it was even launched?

Why not train support staff to be able to answer questions about it accurately and in a timely manner, seeing as it’s a known issue?

I contacted support about this just after the bug emerged. It took six weeks to get a reply, then the reply completely ignored my original question, so was useless.

Here we are several years later and new users are still coming across the bug, wasting their time trying to find a resolution.

4 Likes