Inspector 'Pin' not working for Instrument Tracks

Absolutely agree. The functionality is there, but it does not work/is buggy.

Saying it was not developed for instrument tracks is just not true. Obviously it was developed, because its there, but does not work. It is clearly a bug.

And the thing is, the solution is already there. The code already works for other track types. Just copy it over there, check if it works and move on. There is nothing really which has to be recoded.

EDIT: Also it would not make sense to have pinned tabs for all kind of tracks, but not instrument tracks, why the hell?
I strongly hope they are not just removing the feature and call that a fix “because it was not intended in the first place to be there”, that would most probably be more work than just fixing it properly.

Also: Thats my problem with most “inconsistencies” I encountered with Cubase. You often get the answer that “it was (not) intended to work like this” from Support or Devs even if other similar operations work in a completely different and much easier and objectively better way. To me these are not feature requests as they would say (like it would be the case here) but more like half baked features and therefore issues.

1 Like

We are aware of this. I posted some more background information last year:


Hi Matthias, thanks for the input.
Now I understand that the problem is in fact related the nested section – tabs in a tab – and the coding may not be easy.
I’ll give a quick update on the topic you just shared :wink:

Thanks for the response, although the whole thing does sum up the frustrating way Steinberg operates.

Why advertise this as a feature to begin with, when it was known not to have worked properly before it was even launched?

Why not train support staff to be able to answer questions about it accurately and in a timely manner, seeing as it’s a known issue?

I contacted support about this just after the bug emerged. It took six weeks to get a reply, then the reply completely ignored my original question, so was useless.

Here we are several years later and new users are still coming across the bug, wasting their time trying to find a resolution.


…and is one of the reasons I sold my 10.5 licence. I just bought a 12 licence and find things still not fixed. I must be mad.

Please see Inspector 'Pin' not working for Instrument Tracks - #23 by Matthias_Quellmann

This thread started 6.5 years ago. It’s just another example of things that go for years without being addressed. Functionality that looks to be there but actually isn’t. It’s a dog’s dinner.

There is another topic in which Steinberg staff is participating, so I’ll close this one.