Install failure

I’m installing Wavelab 7 on my Windows 7 PC and I get the following error:

“Error Changing Registry Data”

Then I get a message saying that all components are being rolled back and the install fails. Anyone know what to do in this situation?

Thanks

AB

Try running the install as administrator.

I just bought Wavelab7 and have the same problem (“can’t change registry data”)
I tried running the *exe as administrator and that didn’t solve the problem.

I filed a support ticket and have been working with Jeff Deno–he thought it might
be a defective install disc and attempted to mail me another one, but it’s been over
a week and I haven’t received it.

I got the idea this morning to download the trial version to see if that works (I’ve already
successfully downloaded the license to my eLicenser, so it would likely come up
in non-demo mode). However, I’m still getting the same error even with the downloaded
trial version, so a new disc probably won’t help anyway.

The key that can’t be changed is HKCR.ogg\OpenWithProgIds

AB, did you ever get this resolved? Any/all help is appreciated!

Barry Simon

HKCR.ogg\OpenWithProgIds

Then try to erase this manually with a registry editor, then try to reinstall WaveLab.
I guess another software in your system, has put a lock on this registry key.
Another installer won’t help.

Hi PG,
I FINALLY got this resolved, but it took a lot of registry voodoo. I didn’t have to delete the
OpenWithProgIds key, but I did need to assign full permissions to .ogg

I’m using Win7 64-bit. I did an OEM install last summer and just allowed the ‘typical’ installation.
Unfortunately, this doesn’t seem to assign even Administrator permissions to the HKCR tree.
(Another non-obvious clue for non-WIn-experts like me: HKCR is short for HKEY_CLASSES_ROOT)

For anyone else suffering from this problem (and I lay this at the feet of Microsoft), I found the following
article to be very helpful (despite the example being for a different key):

http://www.raymond.cc/blog/archives/2009/03/05/full-control-permission-to-delete-or-edit-restricted-windows-registry/

The trick is:

  • assign permissions to HKCR first, and under the owner tab check the box that says ‘replace owner
    on subcontainers and objects’. Don’t worry if you get a msg saying it couldn’t change all keys…
  • then go to .ogg and set full permissions for the user/group names that appear–for me this was
    OWNER RIGHTS, SYSTEM, and msiserver.

Anyway, thanks for your suggestion–I’m just happy to finally be able to use the product after a week of
frustration…!
Barry

Thanks for the info. This corresponds to my original guess:
“another software in your system, has put a lock on this registry key.”

But which one and why, will remain a mystery.