Instrument name edit

Dear Daniel and Dorico members,

I have a problem with some instrument names (badly localised A and B flat clarinets, in French). I cannot find the way to get rid of the automatic mention of A or Bb in the name — which would allow me to write it nicely (Clarinette en Sib, Cl.Sib for short name, or Clarinette en La, Cl.La).
Where is that option ? I remember Daniel suggested me something like a month ago, but I cannot find it back…

Layout Options: Staves and Systems: Show Transposition in Staff Labels

Thank you Steve ! It was under my eyes all this time and I could not see it !
[edit] Actually it does not work… Or partially, so I suspect there is a bug here. My B flat clarinet shows “Clarinette en Sib” BUT my A clarinet shows “Clarinette en La dans A” and “A Cl.La”, which is totally wrong.

Just tried it out and I still get the transposition suffices even if unticked for clarinet in Bb and A.
Either a bug or else it is affected by another setting somewhere…?

I think that it is in fact affected elsewhere. It took me a long time to get it all figured out; here’s what I have come to believe will work to give us the names we want, without any transpositions included.

First of all, be sure you have the upgrade to v. 1.0.10—there was some kind of bug in v.1 that affected names, though I can’t remember right now what it was.

As stated a couple of comments earlier, if you don’t want the transpositions to appear in the Instrument Names, start by deselecting Show Transpositions in Staff Labels in Layout Options: Staves and Systems. Then read on.

To me the thing that is confusing (and took me a long time to understand) is that the names of the instruments as they appear in the SCORE and the names as they appear in the PARTS are set in two different places, both in Setup Mode. So go into Setup Mode for everything below.

  1. THE SCORE NAMES (the ones that appear at the left of each staff in the score): These names appear to be governed by the names of the Players (left side of the Setup Mode screen)—but NOT the names you immediately see. Those appear to be only our own identifiers, so we know which instrument we’re looking at. We can call those anything we want, and they won’t show up in the score or parts.

To set the names that will appear in the score, click on the expansion arrow to the left of the immediately-visible name, and you’ll get a dropdown name—THAT’s the one that matters. When you hover the cursor over that dropdown name, an arrow appears the right of the name; click on that, then choose Edit Names from the popup. Whatever you type into those name fields (Singular and Plural, Long and Short names) will appear in the score.

  1. THE PART NAMES (the ones that appear at the top of the first page of each part): These are set on the opposite (right) side of the screen, below Layouts. They are in fact the Layout Names, and they are the names that appear in the parts, assuming you don’t change the default {@layoutName@} token in the Master Page setup for parts. With those Layout Names, just edit the immediately-visible names—there are no “drop down” names as there are under the Players Names on the left side of the screen.

So if you get all those names set the way you want them on both sides of your screen, under Players for the score and Layouts for the parts, AND deselect Show Transpositions in Staff Labels (Layout Options: Staves and Systems), then you should get the names you want in both the score and the parts.

I think… :slight_smile:

Thank you Lew for your detailed reply.

The problem I encounter is with the score names, i.e. the singular and short names which are used in my score, and that still display wrong localised transposition names, even though the layout option, systems and staves category, “show transposition in straff labels” in unticked.
I think it is a bug, since it works perfectly with my Bb clarinet, but not at all with the A clarinet.
Any suggestions from Dorico’s team ?

Sounds like you understand it at least as well as I do, Marc; good luck with it!

Some instrument types are set to always show the transposition, even if you specify that the transpositions should not in general be shown. Clarinet in A is one such instrument. It works this way so that you can specify that e.g. trumpet should not show a transposition (since unless otherwise specified you would assume a trumpet in B flat) but still see an unusual transposition for e.g. clarinet in A (since unless otherwise specified you would, of course, assume a clarinet in B flat too).

You will be able to edit all of these settings in future, when we have a dialog that allows you to edit and define your own instrument types.

A couple of questions:

  1. Is it possible to have the instrument name at top left of the parts shown like “Trumpet in Bb” (with the right b-symbol) and not “Trumpet (B-flat)”
    B-flat.png

  2. As it is now (as I can see) the instrument change instructions can be either abbreviated or the full name. I like to have the first reminder ( e.g. “To Flh”) abbreviated, but the second one, where it’s time to play the full instrument name. Is that or will it be possible?

  3. I’d also like to have an option to skip the first reminder since it sometimes it gets a bit messy with all reminders.

  4. I guess my last question is maybe a bit for the future, but anyway…
    In my jazz scores I like to use the Reprise-font for the Technique-text and instrument changes. (see “Jazz-text”) To make that work in Dorico I guess there must be a way to define the instrument change labels and also a possibility to manually move the labels to a proper place in the score.
    Jazz-text.png

Thank you Daniel for your answer.
The problem in showing the transposition whatever the options is that it is ok when the localisation is done… As is now, in french, it really does not work ! So I hope my two clarinet players will not mind about labels as much as I :wink:
I am confident that this will be handled in the future.

Dear MatsHall,

Lew and I have been trying a lot about those labels, I think I have some clues now. You can choose whatever you want to appear on the top left of the parts, it is what Lew called Part names (the names you see in the left panel, in Setup mode). If you can write a real flat in this area (I think it is layout name in paragraph styles, in Engrave mode), then it will appear ! Honestly, I am trying to find the workaround, and it is not easy…

Oki, thanks MarcLarcher!
I guess it’s tricky since you have to mix two different fonts, one for the text an one for the flat-symbol. So I’m wondering how it works with the staff labels in the score because they look exactly as I’d like the instrument names, top left on the parts, to look like.
I don’t really understand how to add the flat-symbol, but I guess you’ll come up with something i due time.
Right now I’m just fiddling around on my spare time to learn the program so I can switch from Sibelius when all the features I need for my work are integrated.

Cheers!
/ M
B-flat.png

Well, actually THAT b flat in the staff label is added automatically, and I understand that you would love to have it in the part name too. All these details will surely be added in due course, but I think it is important for Dorico’s team to have our feedback, even on these little things.

One correction: the part names, as I call them, are the ones on the RIGHT side of Setup Mode, not the left side. They are called Layout names, and they are the names that appear at the top left corner of the parts.

Ah, so on the left side of setup mode (Players) I edit the name shown in the score to the left of each instrument and on the right side (Layouts) I edit the name shown top left on each part. And that little refresh button copies the entry from the player/Layout on the opposite side on the setup page. I think I get it. :slight_smile:

So hopefully, in the future, the Layout Option “Show transposition in staff labels” could also affect the instrument name top left on the parts with the right flat-symbol as it does in the score, or?

Thank you for the correction, Lew ! I did not see that I can change those names on the right — they were the mere copy to the name on the left for me… But actually, I can then change the ones one the right and it does not change the name of the player on the left ! Cool

Hopefully, in the future, it will be possible to specify these individually per instrument and layout. For transient orchestral parts I never feel the need to specify ‘Horn in F’ but definitely need to specify ‘Trumpet in Bb’ or whatever.
Always specifying transposition doesn’t bother me in English unless I need the space!

Right, Marc. The names on the right appear in the parts; the names on the left appear before each staff in the score.

Clear as mud? :slight_smile:

Clear as mud ^^
The tricky part is that, on the left, there are two kind of names. The names of the Players (which end up on the right if you do not change those latters) AND the names of the instruments (which you have to edit opening the panels on the left). Or am I wrong ? If I am right, I wonder if this could be made in a clearer way…
Anyway, the real problem I had cannot be solved yet, as an A Clarinet will never show “Clarinette en La”, whatever my efforts :wink:

Thanks to all for clarifications and workarounds, they have helped me create scores and parts close to what I want them to look like.

I have one issue left, and it is with an instrument change.

Layout options > Staves and systems > Show transposition in staff labels > OFF. So far so good.

Then, I have a player with three instruments.

For one of those three instruments, I have given “Pikkolo-Trompete in B” as its Singular name ([instrument] > Edit names > Edit instrument names dialogue > Singular full name).

In Setup mode, in the player card, the instrument is nonetheless listed as “Pikkolo-Trompete (B-flat)” (my emphasis). I don’t know how to remove the “(B-flat)”, and it might or might not have something to do with the actual problem (below).

On the right hand side, the Layouts panel, I have named the player/part “Trompete II in C, Pikkolo-Trompete in B & Kornett in B”.

NOW: in the part, when I want the player to take up the piccolo trumpet, I have made a custom prefix: “nimmt” (“takes” in German).

The result is:

nimmt Pikkolo-Trompete in Bb

(… my emphasis).

Any way to remove the “in Bb” in the instrument change instruction? I don’t know where it’s coming from or where to go to remove it.