Instrument name in Italian

Hi,

I changed the language option to Italian in the ‘Language’ category in the ‘Engraving
Options’ (Engrave mode > Engrave menu > Engraving Options or press Ctrl/Cmd+Shift+E).

I did not read all names, but I found a typo in the name of violin:
In the window for adding player, ‘Violino’ is correctly appears. However, ‘Violin’ appears in the staff when selecting it.
Could it be fixed?

When you say it appears “in the staff”, where exactly do you mean?

Did you change language before you created the instrument? If not, that’s your problem - you’ll need to create the player again, and the new player will display with correct Italian instrument names.

Please watch the link: https://www.dropbox.com/s/cnfy92nmjbk99w2/violin%20staff%20name%20in%20Italian.mov?dl=0

Could you reproduce it?
In the video link, I did not show the screen of other modes. However, the staff label is always displayed as “Violin” in the writing mode, the engraving mode and the print mode.

One more question:
I would like to know how to set the default instrument language to Italian.
Is it possible?

Dear prko,
Note what pianoleo has asked. If you already have chosen the instrument, it will not change its name to change the setting to Italian names in Engraving options. If, on the other hand, you create the instrument from scratch after having selected Italian names, or if you change “Violin” to “Violino” through the context menu > Change instrument, the “Violino” name should appear as expected.

Once you’ve selected Italian as an Engraving option, you apply, and press the button on the bottom left “Salva come predefinito”. All new projects should have their instrument names in Italian. Only the new ones :wink: For the others, use the “Cambia strumento” command in the context menu.
Hope it helps

Thank you. I now understand.
The problem is solved.
It was my misunderstanding. In a new project, I must first change the instrument language, then should create instruments.

I have successfully changed the instrument language to Italian as well!

Thank you again.

Something weird is happening when I try to change instrument name:

  1. When I go to Engraving options > Language, and change to ANY new language, the dropdown menu goes nuts (see attachment).
  2. After applying the new language change, and THEN adding a new instrument, even though the selection of instrument is in the new language, when added to the score it’s still in English. I can manually change each instrument name, of course (not ideal); but the problem is transposing instruments… transposition is still in English (e.g. Clarinete in Bb, Flautín in Eb, etc.).
    Screenshot.zip (384 KB)
  1. Just click the white space in the dialog box and the menu stops jumping. It’s not unique to you - it’s Dorico 2.2 on every computer, both Windows and mac.
  2. Indeed: changing the language will only apply to new instruments, not existing ones, and the translation work of transposition hasn’t yet been done (and could be considerable, thinking about it). There are workarounds for this that involve editing the instrument names manually and turning on and off particular options in Layout Options - it’s come up multiple times in the last week alone.

Thanks, pianoleo, for your response; good to know it’s not my computer going crazy (regarding the jumping menu).
About issue 2, as I just wrote, I was expecting the language change to apply only to new instruments. That’s why I changed language and THEN added new instruments. But even the new instruments added are still in English, not the new language. The new language is apparent only in the choosing window, but when added to the score, it’s added in English every time.
Regarding transposing instruments, the translation HAS been done because I’ve already used it in Spanish and in Italian some months ago, when changing language worked fine. I have no idea what happened now that it’s not working correctly.

The translation of the instrument names has been done, but not of the transpositions. You can’t automatically have Trompete in B (meaning trumpet in b flat). You can get the Trompete bit automatically, but telling it that H = B and B = B flat can’t be done automatically.

I have some scores with “Clarinete en Si bemol” (meaning Clarinet in B flat) made automatically by Dorico. I get what you say about B and H, but at least in Spanish it used to work correctly translating the transpositions. That is, until now that it’s not translating anything.
Since I’m manually labeling instruments right now (while I get an answer about this problem), my main concern really is with the “in”, since I can’t change it. Trompeta IN Bb, instead of Trompeta EN Bb.

You can change it if you turn off the transposition in Layout Options, and then add it back in manually (within the Edit Names dialog).

Pianoleo’s solution is what I’ve been using, since in French we have Clarinette en sib, and I would never get the “en”… So if you deal with everything manually, turning every automatic transposition display off, you can pretty much achieve anything you want. But you loose the benefit of all those automated stuff in Dorico which are part of its charm.

Thanks again, pianoleo. And thanks MarcLarcher. I guess I’ll have to do everything manually meanwhile.

For what it’s worth, I don’t think it’s ever been possible to do this automatically. It’s entirely possible that I’m wrong, of course.

Dear Leo,
I do not think it has ever been possible, hence my question during the Discover Dorico… I’d like to know how high on the priority this is — after all, I do not produce ANY score in english language! But well, since it is perfectly achievable with the “new” labelling functions, I guess this is not as important as it seemed the first time I had the problem (like in december 2016!)

It remains on our backlog, of course, and we do plan to address it, but it’s not trivial due to the complications of plurals, genders, ordinals, etc. in the various languages we support.

Thanks Daniel!!! And a merry Christmas to you, your family and your team!