Instrument names in parts

No that wasn’t it for me—it had defaulted to the right places. It’s just that the {@layoutName@} token wasn’t in the Part Layout. However, I’ve now added it and made it the “template” (can’t remember the Dorico term) for all future scores and parts.

Thanks again for straightening me out on this one!

I expect what happened, Lew, is that you have clicked the ‘Save Default for Parts’ button in Layout Options with a set of options that were intended for the full score, so if you look at the “Master Pages” section of the Page Setup page in Layout Options, you will see that the chosen default master page set is “Default Full Score”, but it should be set to “Default Part”. You can select all of the parts in the left-hand list in Layout Options to make this change, and then you’ll find that the instrument name appears there by default.

PART NAME NOT APPEARING

I had the same problem as well - the instrument names not appearing in the parts at the top of the page. I did as was suggested above . . .

In Setup mode I chose Layout Options, Page Setup, I selected only the part layouts, and chose Default Part under Master Page set. And then applied.

The part name appeared on all the part layouts except one, the final part, Trombone. I checked and the Trombone is set for the default part. Why is the part name not appearing only in one part?
Screen Shot 2016-11-21 at 1.24.46 AM.png

It’s 12 hours later. Has no one any thoughts on this?

David, if you click on the little arrow, next to “trombone” in the players panel, than you can change the name of the instrument. That’s the name, which is displayed in the score and parts. Have you changed anything here?
Another try: what do you see in the part, when you switch to engrave mode?

That indeed looks odd to me.

What is shown in Engrave mode, do you see the token?

Robby

thank you HeiPet
When I click the arrow next to trombone in the players panel, it says the proper player name just like all the rest in the players panel. I don’t recall making any changes here.

In Engrave Mode there is no space for the instrument name, though it does appear in all the other parts. So strange, I guess I can add it in by hand.
Screen Shot 2016-11-21 at 3.01.10 PM.png
Screen Shot 2016-11-21 at 3.04.46 PM.png
Screen Shot 2016-11-21 at 3.05.38 PM.png

no token, nothing.
Screen Shot 2016-11-21 at 3.04.46 PM.png

What does the default master page layout look like?

Robby

Sorry Robby, I don’t know anything about master pages. I did double click “First” under Master Pages, Current Set, Default Part. Is that what you mean? This is what I saw, see attached. Looks good to me, the part name is there but does not appear.
Screen Shot 2016-11-21 at 11.16.48 PM.png

That’s exactly what I meant…

And you are getting names on the other instruments?


Robby

Yes, all the other instruments except the final one, the trombone part.

Here’s another thought… Maybe you accidentally erased the text box on the trombone part.

Does your page setup look like this in engrave mode?
Screen Shot 2016-11-21 at 9.54.24 PM.png
If you see any red or green outlines, if so that means a change has happened somewhere. If you see the red or green outline, and select the page, right click, and remove edits or restore default, or something… it might fix the problem.


Robby

Sorry, it’s a red arrow in the corner…
Screen Shot 2016-11-21 at 9.59.27 PM.png
Robby

Thank you Robby, that seemed to do it. It’s all good now. Still don’t quite understand why that worked but glad it did. I really want a good manual to understand the intricacies of this program. Thanks again.

Glad I could help!

The page layout/Engrave mode thing is really new compared to anything I have seen in music notation. It seems awesome, but it is a little daunting. A manual would be great. And I believe “work in progress” manual will be out soon.

Robby

This is why Engrave mode is such a nightmare. Simple things should not take multiple posts and google searches. If instrument names are selectable in Layout options it shouldn’t be hidden somewhere else. I have been using this platform since it came out and every time I open it I spend more time googling answers to simple tasks rather than writing.

Resurrecting - Is this option available in Elements?

I’m not able to see part names. I’m reluctant to change the only option I can see in Layout Options, which would be Page Setup / Master Page / Default Full Score (as it currently is) to “Default Part” - this may change my entire layout?

How do I set it so that when I create a new layout with just the one instrument “part” (I hope this is the correct way of creating parts) that layout shows the instrument name top left, as the example given earlier did?

Thanks

Ah goodness! I’ve been making a fundamental error since I started using Dorico - don’t know why but instead of creating new “Parts” layouts, Ive been creating “custom” layouts.

So my headings are there.

But when I create a new Part Layout ALL the flows are pre-selected, and every time I untick flows I don’t need, the screen scrolls all the way left to the beginning and I have to keep scrolling to the right untick the rest, one by one. With a twenty something song musical that’s a lot of flows to scroll by.

Is there no way of creating a new part with no flows ticked?

By default every Part Layout will have every flow ticked. Right-click on the Part Layout and you should see this: