Instrument numbering is not disappearing after removing duplicated instrument

I have a choral piece for SATB, in which I initially had two Soprano part (Soprano I & Soprano II), but later decided to have just one “section player” for Soprano and use “divisi” instead.

However, Dorico still displays the reamining soprano instrument name with “I” after it, and I couldn’t figure out how to get rid of it:


Any help?

Maybe at some point the number I has become an explicit part of the instrument’s name. When you click the three dots to the right you get a contextual menu with an option to change the name (or reset it to default). If the explicit ‘I’ isn’t there at all, then I guess it’s a bug, and I’m sure the developers might want to see the project itself to examine it. In that case you might try the following: create a new empty section player, drag the soprano (the blue instrument) to it (this moves all the music along with it), and delete the original soprano, which now is probably called Empty-handed player. Make backups first before an operation like this.

Hey, thanks for the suggestions.

Unfortunately, I tried to do manual rename, but that didn’t seem to work:

The name looks correct.

I also tried creating a new section player as you suggested and moving it, but it didn’t work either.

What happens when you first change the name to something else, say ‘Sopranooo’, apply the change, then change it back? Maybe you break the remnant of the automatic numbering with it? Or even more thorough: assign a totally different instrument (say flute), then change it back to soprano?

Nice!! That actually worked. Thanks.
Still seems like a bug in Dorico though, but thanks for the workaround.

There are no known bugs in this area in Dorico. If you find that the instrument name continues to show a number when only one instrument of that kind remains in the project, chances are you have overridden its name, and need to reset it. If you want us to look into it further, please provide the project file.

Emm… I tried to reproduce the issue and wasn’t able to. I’ll let you know if that happens again, maybe I’ll have more information.

Right now I have already changed the file so I don’t have a way to show you how it reproduces.