Instrument Track input too early!

Hello people! I hope you are doing great! I’m coming this way because i’m struggling with this Cubase Issue:

I start recording a Instrument tracks, i play the piano, but i can see my inputs are writen too early in the part! I f i use AQ it gets even worst! is there a way to fix this??

Midi controller: M-Audio Keystation49 MK3
OS: Windows 11

T.T i love cubase so much but this is destroying me, i wasn’t able to fix it! In another DAWs there is an option call MIDI offset, then you can set custom Input ms to write the input earlier or later! But i can’t find nothing like that in cubase! HELP MEEE! T.T

Hello, tried enabling the “Asio Latency Compensation Active by Default” and “Add Latency to MIDI-Thru Processing” options in Preferences→Record→MIDI?

1 Like

Sir! You are amazing! This worked perfectly! THAAAAANKKKKSSSSSSSS

1 Like