Instrument track punch-ins delete existing information

I’m hoping someone will know what setting is causing this to happen. When I punch in on an instrument track, the new information records just fine, but when I stop recording, Cubase retroactively places the punch-in point at the beginning of the measure in which I executed the punch. As a result, all of the matieral in that measure, prior to the point at which I actually punched in, is replaced by silence (deleted.) Does anyone know why this is happening, and how to prevent it?



I haven’t figured out what’s causing this problem, but I did discover a workaround. The problem only occurs when the ruler shows beats/measures. If I switch the ruler to show seconds/minutes, the problem goes away. So now I record with the ruler showing minutes/seconds, and then switch the ruler to show beats/measures when editing or quantizing.

Hi Tommy, I think you have “Snap MIDI Parts To Bars” on? Go to “File>Preferences>Record>MIDI” and untick it and check what happens when you switch your ruler back to “Bars+Beats”. Hope that helps.

Have you got ‘replace’ rather than ‘merge’ set in the midi recording preferences ?


Yep, that was it! Thanks!! :slight_smile: