Instrument tracks (vst) recording other audio tracks

Got a new problem. If I set up an instrument track for my VST Halion or Vhorns or SWAM audio sampling and start recording that track and all other audio tracks in the project are being recorded with it

I have never had this problem before is Cubase 12 professional latest version-help!!

Photos included

This description is kind of ambiguous if someone doesn’t already know what you are experiencing. It sounds like you are saying that when you record on an Instrument Track (which only records MIDI and not Audio) that you are getting Audio from other Tracks mixed in with the VSTi’s sound - which can’t really happen.

My guess is that you mean when you Record MIDI on the Instrument Track the Audio Tracks are also recording Audio content on them at the same time. This is what would happen if these Audio Tracks were also Record Enabled.

As a side note, you should check out Windows Snip & Sketch (it looks like you are on Windows) which is a much easier way to create screen captures and post them - you don’t even need a file just copy & paste here.

I add an instrumental track to my project. I assign it to an instrument in SWAM audio modeling I start my recording and I’m watching the track. I see data when I’m not even playing and when I’m playing there is data being added to what I’m playing and it’s coming from the audio tracks because all of my midi tracks are muted. I hope that clears it up.

Alan Russell

Can you post a screen shot of the Track(s) involved from the Project Window after this has occurred and make sure to include the inspector.

I’m not familiar with SWAM, does it have any Audio Inputs?

So are you saying that the Audio Tracks are being converted to MIDI data and that additional MIDI data is getting recorded onto your Instrument Track?

Do you by chance have a Chord Track in your Project which is set to play on Monitored Instrument Tracks - which is the default. That could get recorded as additional MIDI data on your Instrument Track. If so Mute the Chord Track.

There is no chord track in the project
I will get you photos of the inspector. I just need a little time I’m with the wife at the moment and I thank you for your on going help.

Alan Russell

If that was the case then I could understand why those audio tracks are getting recorded with that one instrumental track but I have no way approving that unless I am missing something… just to reiterate, those midi tracks are all muted. I keep them in case I want to view them thru the score editor. You

I’m not sure I’ll get those photos from the inspector this evening, but definitely by the morning

Your problem definitely sounds like you have Loopback enabled in your driver, so everything that goes through the interface’s output is sent back to inputs 1/2. You’ll probably want to disable it.

The motu m4 loops are unchecked-same issue
Why it’s still says active even with it is unchecked under the visible category I can’t comprehend

No, this is a setting inside your MOTU control panel, not the actual audio connection.
What you have disabled are the virtual loopback channels, but there can still be a setting that allow the loopback to be sent to the 1/2 inputs, so if your audio track have 1/2 as the input, it will record everything that you hear.

I am going to take a look at this this morning. I just woke up in South Florida having a doctor’s appointment at 9:40am EST I will be running an experiment with two tracks one being a piano audio track and the other being a VST Instrumental track
I will start off with Halion sonic 3 then Vhorns and finally Swam using the Yamaha genos keyboard

I will still need to know how to get into the MOTU M4 control panel to check any loop back settings

Thank you all for your continued assistance and I will talk to you a bit later.

Alan Russell

Alan Russell

Press this button:

Ok guys, I think I figured out the problem

I went to my windows, 11 screen, and in the bottom right corner I went to sound settings
When I opened it up, I saw an item called “loop back,”and it’s radio button was not filled with any color, but there was an arrow to the right, which I clicked and I noticed that it said “Allow”

I changed it to “Don’t Allow” and went back to my project. Finally None of my audio tracks would be getting recorded to my new VST instrument track for either Halion sonic 3, Vhorns or SWAM, audio sampling. Photos included