Inter-app audio will not record with iOS 1 4.4.1

I purchased C3 yesterday morning and am very impressed with the difference between Cubasis 2 and 3. I was able to find the solution to my inability to preview sounds I reported yesterday and have deleted the post.

But I updated my iPad operating system to iOS 14.4.1 in the afternoon. Before the update Inter-app audio worked great. But now since the update I can’t record the listed inter-audio apps in the Media bay including Nanologue and others. What happens when I assign, for example, Nanologue to a track the Nanologue icon comes up as the source, (and Nanologue is opened) but if I click on the icon I am taken to the Nanologue app itself but the “instrument” rectangle at the bottom of the Cubasis track screen is empty with just the name Nanologue displayed- no keyboard for Nanologue input.

But even the if I try to record on the Nanologue track by tapping record in Cubasis, then going to the Nanologue app and playing, nothing gets recorded. And back on Cubasis in the track I am trying to record in, the circle keeps going around and never stops. But if I assign Nanologue to a previously recorded midi track (any instrument recorded) the track plays the Nanologue. This situation is the same whether I assign the incoming routing to Inter-App|Nanologue or “any midi port”. Further, in the Nanologue app “Cubasis” is displayed at the upper left corner and the microphone icon in the upper right corner is red. So how do I solve this?

Hi @MercedesCP4,

Thank you for your message.

The issues you describe are unrelated to the iOS update, here’s how to fix them:

  • IAA and AU Icon issues are known iOS issues. Fully reboot your iOS device to resolve that.

  • Tapping a MIDI track’s icon always opens the instrument rack, not the keyboard. To open the keyboard too, tap the KEYS button in the top left corner.

  • Notes played in an IAA app are not recorded by Cubasis, because this is a limitation of IAA. Notes (MIDI input) for an IAA instrument must come from the host app (Cubasis), unfortunately. That’s why we recommend using AU (Audio Unit) plug-ins, if available, preferably.

  • The red microphone icon and the “Cubasis 3” text in the upper left corner come from iOS, not from any app. iOS informs you that Cubasis 3 is the app you were previously at (go back via one tap), and that an app is using audio input (red mic icon).

For further limitations regarding IAA, please refer to the IAA section in the in-app help or the online user manual.

Best wishes,

Hello Lars,

I want to thank you for taking the time to assist with my issue. I have solved the problem, but here is a better explanation of the problem I had and how I solved it. When I clicked on the Nanologue icon at the left of the track, all that was shown is what is in my attached screenshot 1. This made it impossible to record into Cubasis 3 because there was no keyboard to play. But I discovered, just this morning, that when next I then clicked on the keys icon at the upper left-hand corner of the screen, a keyboard appeared on the bottom half of the screen and Nanologue appeared on the top half of the screen and then I was able to use the keyboard to record Nanologue. See screenshot 2. I tested this with my other inter-audio apps and they all worked fine.

This followed rebooting the iPad as you suggested. So again, thanks for your help.


Hi @MercedesCP4,

First of all I hope you’re well!

Hi @Iskander, Hi @Tech-dance,

Please note that we’ve released Nanologue 1.0.2, which can be freely downloaded on the App Store. The update adds several iOS 15 and iPadOS 15-related improvements and fixes.

Download Nanologue on the App Store.

With this update, it should work fine again to use Nanologue on a Cubasis MIDI or audio track via IAA.

Hope that helps!

Enjoy making music
& stay well,

Many thanks, Lars and team.

Hi @Iskander,

Thanks for your kind message!

Many thanks, Lars and team.

Many thanks to our great engineers making this happen!

Stay well
& best wishes,

Excellent work. Many thanks for sorting this.

So happy :slight_smile:

Hi @Tech-dance,

Thanks for your message.

Excellent work. Many thanks for sorting this.
So happy :slight_smile:

Glad to read you’re happy!
Enjoy using Nanologue!

Stay safe,