Interval popover not working

I just updated to 2.1.10 and the add interval popover doesn’t seem to be working at all. I’ve only tried it on one score - will try it in others to make sure it’s not a corrupted file. Don’t know if anyone else has had the same issue.

Welcome to the forum. If you look in the Write menu, do you see the Shift+I shortcut appear for the Add Intervals Popover menu item? If you make a selection and then choose the menu item, does the popover open?

Yes - The popover is coming up reliably through both keyboard shortcut and the menu. Through some experimentation, I’ve found that it’s working on some staves and some notes, but not on others. I can’t seem to locate a pattern to it - in fact, I even copied some content from one flow to another as a test, and it didn’t work or not work consistently between the two sets of identical material.

K-danger, are you using a microtonal system? Interval popover doesn’t work reliably on that, I’ve heard.

Ah - indeed I am. But interestingly enough, the glitch isn’t only happening on notes with accidentals. I also have lots of stemless notes, and note shapes. But there doesn’t seem to be a consistent relationship with the behavior to any of those things. I’ll update as I’m able to decode anything that might be directly related to the problem.

I wouldn’t label the popover as working “unreliably” with microtonal music – it works exactly as designed.

If you specify e.g. “p5” in the popover, but the tonality system you’re using is set up such that a specific pitch cannot be directly transposed by a perfect fifth, then Dorico won’t do anything, for understandable reasons: you’re asking it to do the impossible.

Here’s a screenshot. I know this is a shot of just the first bit, but the user was entering just a numerical value in a microtonal piece and was not getting the desired interval.

I don’t use microtonal functions and didn’t test it myself, but it seemed the tuning system was the problem. Just passing it along. I can ask the user to post on this thread.

Yeah, I stand by my comment. It’s not unreliable, it just can’t produce impossible intervals.

Yeah… The issue is the same for me. The popover itself is popping over but it’s not adding the specified intervals, for the most part regardless of quality or the intervals I’m attempting to add or whether there’s an accidental present. I am using customized microtonal accidentals with an atonal key signature, but none of the notes I’m attempting to add intervals to are altered with accidentals - although I tested for that (see below). I am able to use the (much slower) “add notes above or below”, but that obviously defeats the purpose.

When using the interval popover I was attempting to test it by simply using a single number to indicate an interval up - no luck. Didn’t work on anything. Same with any interval down and same with indicating “maj” or “major”. However - it DOES work, on most notes, but not all, when indicating a minor interval UP, using any of the usual indications (“m3”, “m 3”, “min3”, “min 3”, minor 3", “minor3”). This last bit doesn’t work where there’s a microtonal accidental (which makes sense in light of Daniel’s explanation above). So I’m going to concur with the “unreliable” assessment so far. Daniel - suggestions?

Surely the quickest way would be to turn on chord mode (Q), then type or play the additional note and add the accidental as necessary.

kdangerjames, you’ll need to attach a project in which the problem occurs for us to be able to provide any further assistance.

As it happens András and I have been talking about the Shift+I popover and support for microtonal intervals in the context of the work we’re currently doing on trills. You can in fact specify a microtonal interval in the Shift+I popover, something which is not currently documented and which I will make sure is rectified forthwith.

In 24-EDO, you can use a syntax like , e.g. 2nd1qt will add a note a whole tone and one quarter tone above the current note.

You can also specify arbitrary divisions in the event that you are using a less regular tonality system, in the form , e.g. 2nd9div will add a note one diatonic step higher and nine divisions higher than the selected note, if that’s a valid interval in the current tonality system. Note that the number of divisions is counted from the selected note, not from the number of diatonic steps, so if you have (e.g.) 53-EDO, each diatonic step is itself 9 divisions, so to raise a note by a third and a 4/9ths sharp, you would specify 3rd31div (9/53 x 3 + 4/53 = 31/53).

I hope this makes some kind of sense to you.

Thanks Daniel - sorry for slow responses. Lots of travel right now. The microtonal interval explanation makes total sense. I haven’t had a chance to try it yet, but will let you know when I do. I should be getting to some of that over the weekend.

So I’ve believe I’ve figured this all out completely (but not resolved it) - the microtonal scale I’m using is 48 divisions, but I’m using a simplified custom set of accidentals (all microtones are variations on slashed or stemmed arrows - the system isn’t unique to me), rather than one of those supplied. I found the Dorico interface for accomplishing creation of the symbols to be simple and elegant, and I in included the standard flat natural and sharp in my tonality system. However, unless I’m mistaken, there’s not a place in the Tonality System creation pane or editing frame for me to define the number of divisions for each of those accidentals. So the reason the Interval popover isn’t even inputting standard intervals, is that there’s not even a definition of divisions for standard naturals, flats or sharps, let alone the microtones. Is there a way for me to define those intervals for Dorico in order to make the Interval popover work with my custom tonality system?

OH - at the same time I’m having problems with instrument changes mis-aligning in some frames - I’m using tons of instrument changes to accomplish swapping from regular staves to single line staves. Is there either a simpler way to accomplish this, or a fix for the misalignments?

When you add a new or edit an existing accidental in your tonality system, there is a pitch delta value in the top right corner. It’s in number of division, so in your case setting it for eg -1 it will mean -1/48. In the edit tonality system dialog each listed accidental shows its pitch delta.

Ahh yes - there it is. I was looking right past it. Making that fix did not affect the non-functional interval popover, but I need to try it in a fresh file to get an accurate test, I think. Thanks for the patience.