Invisible noteheads with stems for glissandi

Hi all - there are at least a couple of older versions of this question (https://www.steinberg.net/forums/viewtopic.php?t=143250), (https://www.steinberg.net/forums/viewtopic.php?t=128808)

I was wondering what the most up to date and clean workaround is for hidden noteheads with visible stems, specifically for glissandi. (and the result wanted in both score and parts) I attached a pic of my typical glissandi writing in Finale (which is an awful process that takes countless hours and still ends up with either gaps or intersections between the stems and lines).


Ideally a native solution with a hidden notehead would adjust the stem to exactly touch the line without intersecting it.

Have you checked out the notehead editor? That’s probably your best bet. Make a custom notehead set.

Make a custom notehead set with only one notehead, in the editor check both “use for durations…” checkboxes, name it Headless or whatever. Be aware to not just delete the old notehead but enter a text element with only a space!
(This is because you need something to select if you want to copy it)
Now select the notes you want to hide, right click, choose notehead/headless

et voilà

Thanks, but with this method the ledger lines remain. They need to go away.
Does anyone know how to get rid of the unwanted ledger lines?
(See the screen shot bar 37, violin 2 (I assume).

Thanks Henrik

You can hide ledger lines as well, via the Properties panel. (Probably only in Engrave mode.)



Brilliant!! Thank you both! Look at this. Beautiful:


If anyone is a perfectionist and you have a stem that’s going to leave a slight gap or intersect, in engrave mode you can just drag the stem handle until it’s upside down, then alt-down the note in write mode until it’s roughly where it needs to be, go back to engrave mode and adjust the handle till it’s just right. (so in that bottom example, the 3rd beat is actually a 3rd-line B) But actually before I did that it was really pretty good already, definitely closer than in Finale.

Awesome stuff! I’ve been labouring on the same issue, but whenever I try to create a new notehead, which means that I choose one of the existing notehead designs and edit it in order to get the invisible notehead, those changes are carried over to very sets which also use the preexisting notehead. :frowning:

How would I be able to create a completely new notehead set which is independent from the ones already provided by the program?

Marco, have you watched this? https://youtu.be/DIeqabJSyT8

Ah yes, now I got it! You people only forgot to mention that one not only needs to create a new note head set, but within it also add a completely NEW NOTEHEAD as well – and only then delete the remaining other pre-existing notehead (w/o modifying it).
Then it all works flawlessly! Awesome!

It’s strange, but if I want to duplicate passages with invisible noteheads (which I created with the editor) and I duplicate just with shortcut ‘r’, the invisible noteheads are NOT dublicated. Only if I take my selecting tool -> choose the whole passage -> command C -> command V…4 steps in place of one. That’s a pity. With normal noteheads, shortcut ‘r’ works perfectly.

Hi Jazzisfaction!
I’m not sure whether it is the same behavior, but you’ll notice that if you hide brackets and numbers for tuplets, and without flags showing, copy and paste, the copied notes are no longer part of any tuplets. This means Dorico copies what is actually visible (or with signposts)
What is surprising here is that copy-paste does work in your case, rather than r being dysfonctional…
Someone from the team might bring some explanation.

if you once took the select tool and selected the passage with the ‘unvisible noteheads’ and you copy-pasted it with command c and command v one single time and you keep it selected, you can go on with shortcut ‘r’ - then it works perfectly :stuck_out_tongue:

I am preparing Dorico tutorials as our school is making the switch from Sibelius to Dorico. Is this what I have to teach young composers or is there a simpler way?

Make a custom notehead set with only one notehead, in the editor check both “use for durations…” checkboxes, name it Headless or whatever. Be aware to not just delete the old notehead but enter a text element with only a space!
(This is because you need something to select if you want to copy it)

Thanks

It’s either that or something like it, e.g. selecting the noteheads and setting their scale to 1% in the Properties panel.

Many thanks for a quick answer!

If Dorico came with a ready-made solution it will be described in the Dorico Operation Manual. I do hope that it will be included in the next version. There are other pre-defined noteheads that are less used then the stem without notehead.

I don’t think a notehead without a head is the ideal solution to this requirement. It should be automatically handled as part of the creation of the glissando. That is something we plan to address, but I can’t say whether or not it will be in the next version.