iOS 8.4.1: any problems?

Hello, just wondering if anyone has had any issues with iOS 8.4.1? I haven’t installed it yet and I won’t until I can be sure it will not break something in Cubasis! I understand that 8.4.1 is mainly fixes for Apple Music and security updates, but you can never be too careful…

I have been using 8.4.1 and so far all seems OK.

I have been creating new projects, importing Audio and midi files via Open In from dropbox. Doing lots of part arranging and Midi editing.
I have only used in-built instruments so far (MiniSampler, Micrologue and MicroSonic, I have not yet tried using AudioBus or IAA since i upgraded.

I have a problem with ios 8.4.1
I have used a Steinberg UR44 connected to an Ipad air for over a year.
I use the supplied Steinberg DSP mixer software and, when recording, Cubasis.
Never a problem.
Immediately after upgrading the Ipad to 8.4.1 the DSP mixer couldn’t find the UR44.

I actually own two UR44s, one in my studio and one as a live performance mixer and interface with Cubase. So I have 2 sets of everything, allowing me to swap cables and even swap UR44s.
No connection.

Hi ellesse,

I assume you’re aware the interface has been set to class compliant mode first.
Please give the iPad a full restart (press on/off button, slide to power off) and try it again.

Please let me know about your results.

Thanks
Lars

I’m new to these forums. Not sure if I should use… private reply, quick reply or post reply. Confusing.

Thanks for getting back to me.
Class Compliant Switch:
Yes, it has been switched to CC Mode all along but I toggled that switch a few times in case the switch itself was at fault.
I did a full restart of the iPad as you suggested . No change.
The message states, Cannot use device. Steinberg UR44. The connected device is not supported.
So the iPad and software ‘sees’ and recognizes the device, then fails to connect for some reason. Correct?
Are there any other settings, either in the iPad or UR44 that may need a reset?

Hi Ellesse,

Here are two more thoughts how to solve the problem:

  • Double check the cables are working correctly (assume you have done that already)
  • Make a backup of your iPad and perform a full restore of the device

Hope that helps.

Best wishes,
Lars

Ok, I’ve also been in touch with Steinberg support here in Canada.
I can’t recall the tech’s name but he is in Toronto.
We haven’t spoken directly [voice mail tag] but his last message to me was that he was aware of the problem, had recreated it, got the same error message and would definitely investigate.
That’s a relief actually, as it suggests that the problem is software related. I’m surprised that no one else seems to be aware of it. Surely there are lots of people worldwide using UR44s with iPads?
I’m not sure how to do a backup of the iPad or perform a full restore so now I’m wondering if I should wait to hear from the Steinberg tech before going that route.

Hi Ellesse,

This message is from Hamburg where Cubasis is developed, tested etc.

We have the CC compatible UR product line at hand and did not experience soft or hardware problem when connecting and using the UR44 device with Cubasis here. Please ask the Canadian support guy to get in touch with me to share more information.

Please check if this link is helpful supporting you in creating a iOS device back up:
https://support.apple.com/en-us/HT203977

Thanks
Lars

Hi Lars,
I really appreciate your attention here and have high regard for your thorough knowledge of both the hardware and software.
Before I found this forum I had been in touch with Steinberg Canada [using the contact phone info from the Steinberg website]. Once I heard that the Canadian support guy had encountered similar error messages I assumed that the problem might not be with my cords, etc.
To clarify, the error message did not come from Cubasis but rather the dspMix software that allows the iPad to control the UR44. When I connect with Cubasis first [rather than the dspMix software] I get no error message. However, in Cubasis, any audio playback [pre recorded files] is choppy and stutters where it didn’t in the past.
I will certainly tell the Canadian tech to get in touch with you as soon as I hear from him.
Thanks again.

Hi Ellesse,

Thanks for your reply.
As stated earlier I suggest to give the iPad a re-install (making sure all files are properly backed up beforehand).

Please keep me updated.

Thanks
Lars

Hi Lars,
Ok, I spoke to the Canadian tech who had encountered the same error using an iPad with ios 8.4.1
When he tried to run ‘dspMix’ the message was:
“Cannot use device. Steinberg UR44. The connected device is not supported”.
He was able to correct this by changing the order in which the hardware was connected. ??
So, I’ll give the iPad a full restore but would like to know more about that.
Does ‘full restore’ mean re-setting the iPad to it’s factory settings?
Will I have to re-install all my various software etc?
Thanks again

Hi ellesse,

Here are some links that explain the procedure and options:

https://support.apple.com/en-us/HT201252
https://support.apple.com/en-us/HT203977

Hope that helps!

Best,
Lars

Ok, where to start? I wonder if this discussion should be posted in a different area of the forum because it no longer seems to be an 8.4.1 issue?
Review:
I used the dspMix software to control the UR44 successfully for over a year.
The iPad wanted to upgrade to 8.4.1 - I upgraded and at the next live gig the iPad failed to see the UR44.
I went through all the procedures suggested here in the forum - no improvement.
Next, I performed a complete iPad restore, factory re-set, re-install. [it seems to have many names]
I used iTunes for the backup/restore, which by the way made the process very difficult unless I upgraded to the latest operating system. I now have ios 9.0.2 on the ipad.
When the restore was finished, I connected the UR44 to the iPad and it worked - 1/2 the time.
I tried restart, tried connecting hardware in different order, different cables etc. No improvement.
I performed another complete reset and it now works some of the time. When it seems to be stable, it often freezes. I shut down, restart, try different order of connection etc but it’s not reliable. I’m a professional musician so I can’t trust this gear for live performance. I have no idea where the problem is.
At this point, I’d be happy to stop using the iPad and use a PC. The UR44 connects seamlessly to my PC laptop BUT the dspmix software needed to control the UR44 is far too small on the laptop screen, not even useable.
Any ideas or help would be appreciated.

Hi Ellesse,

I’m sorry to hear that you still seems to have issue with dspMixFX on the iPad.

Please open up a topic in the dspMixFX forum, since the issue is not Cubasis-related, correct?
Afterwards I will close/move this topic to the right forum.

I will try to have the issue tested internally once more and will get back to you.

Thanks
Lars