iPad Pro 11" 3rd gen (M1), iPadOS 16.4.1, Cubasis, and USB audio interfaces

OK, not sure where to post this, please move to an appropriate forum if this isn’t the place. Last year I was using Cubasis on the iPad in title to do some audio recording/mastering and everything was working fine. As far as I know, at the time, iPad was running 16.1 or maybe even 15.xx

I recently had to do some more recording and I connected the same USB audio interface that worked previously, and now it’s not getting detected, in Cubasis, GarageBand, or any other audio app. The device itself (TASCAM US-4x4HR) is blinking the USB connection light, to signal that something is wrong.

I’ve connected it to a PC and its working fine, so it’s not the unit. My friend happens to have exactly same hardware, but still running 16.1 (auto-updates are off) and the interface is working there.

People here with M1 iPads (or specifically 11" 3rd gen, in case its somehow platform-specific), with any kind of USB class audio device (multichannel interface, mixer/whatever), is everything working for you with 16.4? I tried the 4x4, a random USB2 → XLR Mic preamp I had laying around, and an old Roland UA-3FX in ‘standard’ (USB class) driver mode, and NONE OF THEM WORK. I’ve reset my iPad completely, still nothing works.

Any ideas?

Hi @timecop,

Thanks for your message and a warm welcome to the Cubasis forum!

Cubasis for iOS fully supports the use of class compliant audio devices.
Your issue may be related to a broken adapter or something similar.

I’d suggest to get in touch with our friends at TASCAM, to find out the cause of the problem. Before doing so, you may check that Cubasis has mic access (following the steps below).

Hope that helps!
Please keep me updated!

Best,
Lars

Granting mic access to Cubasis

Starting Cubasis the very first time, a popup asking your permission to use the microphone appears, which has to be accepted.
If you tapped “no” by accident, please change the setting manually as follws:

  • Please go to the iPad settings
  • There please go to Privacy / Microphone
  • Please make sure to enable Microphone use with Cubasis.

Please let me know if this helps to solve the problem.

I wouldn’t be posting here if I haven’t already exhausted all the tests I could do here.

  1. I have tried US4x4HR, generic USB audio class mic preamp, and roland UA-3FX. None of them worked under 16.4.1
  2. I have access to identical ipad still running 16.1 and all 3 of the above devices are working there.
  3. I’ve tested direct C-C connection, C-C hub, etc. On the 16.1 device all those combinations work. This is not a “broken adapter” issue.

Which is why I posted if there’s been some feedback on 16.4.x specifically breaking USB audio class devices.

Thanks!

Hi @timecop again,

We are unaware about iOS/iPadOS 16.4.1 issues in this regard.

Gave it a check myself, using the iPad mini 6 with iPadOS 16.4.1, Cubasis connected to the EVO4 via USB-C, where things work as expected.

Hope you’re able to resolve the problem.

Best,
Lars

So you have M1 based ipad pro running 16.4.1 and any audio interface works on it with Cubasis? (and yes, i did check mic permission, that is on)

Oops, just read your edited reply. Mini 6 is Axx based. I’ve confirmed with TASCAM tech guys ( who have a similar Axx based ipad, 10th generation or something?) that USB audio class IS working there on 16.4.1. The problem (if any) seems to be limited to M1 based stuff, at least in my testing.

I have an update to this:

  • Continues to not work in 16.5
  • I’ve tested on 11" Pro 4th gen at a shop running 16.4.1 and it IS working there.

So the problem, seems to be limited to 11" Pro 3rd gen only, and in software versions above 16.1.

Nobody on this forum has same ipad and any USB audio interface? :frowning:

Hi timecop,

I am running cubasis on a 3rd gen ipad pro (12.9”) and since a few months having issues too with my tascam US16x08 audio interface. My operating system now is Ipad OS 16.5.1c but the problem has been there before this update.
My problem is: 9 out of 10 times when I start cubasis, only my left audio channel will produce sound. It is NOT hardwire related, because any other youtube audio is without the problem. Then I start the app again, or disconnect my usb-c cable, and unpredictably all starts to work fine. I am using Apple usb-c to usb A adapter. I tried all different sequences in starting up / connecting my audio interface, but cannot detect when works or not.

I know this doesnot help in solving your problem. Just want to let you know that I’m having issues too with comparable set-up. Hope it will be solved.