Ipad Software sending Song Patch changes - Not being recognised

Hi, I used to use Onsong, but i abandoned it as pricing was high, (especially for someone that receives no funding from a church.) and it doesn’t support Smartphones or Windows. I now use Linkesoft Songbook, which works quite well, however I am approaching the 128 song limit of Midi Program changes. The system of using control change/banks, I have been unsuccessful in getting the 2 to communicate, hence why I decided to see if VST Live would work.
I have started some basic programming, but as yet, I have been unsuccessful getting the program changes from my iPad to be recognised in VST Live. I don’t even see them in Midi Monitor in VST Live. Could this be a plug, or have I missed something.


… just give me rough overview about your setup. You are running an iPad. And which app are you using? It’s connected to VST Live. Mac? Bluetooth?
… have you installed VST Live 1.0.40? Released today? Have you tried it with that version? Maybe it’s better now?

See you

Then there is no working MIDI connection or transfer. Check Devices/Connections and make sure MIDI data are actually beeing sent.

Hi, I just did a quick schematic of how it’s setup. I have downloaded the new version, still nothing as is. The Program I use is Linkesoft Songbook which is Multi-Platform, and cheaper than Onsong, but does what I need it to do (usually). I don’t want to downgrade my Samsung Galaxy Fold 3 either. Currently the Command I use is EG: {midi: PC6}. As yet I have not successfully been able to send a successful Patch change using CC commands (It does show up in Midi Monitor. The Ipad is connected via USB. I think I may need to add it as a layer in the patch, and have the iPad set as Input?

Hi, I did as you suggested and checked. The PC Commands were recognised in a generic midi monitor.
However, they did not show in Devices Connections, until I selected the Ipad as an Input. So, I assume I will need to add a layer in each patch especially for the iPad?
Thank you for the tip, and I’ll let you know how it goes.

Hi, still no luck. I have reached out to the developer, as Mainstage also uses PC plus MSB/LSB, but only seem to support the PC command.

Below are the commands:-

Command Explanation Example
N Note (On/Off) N60
PC Program Change PC6
CC Control Change/Bank Select CC100.10
SS Song Select SS99
PAUSE Pause milliseconds before sending next command PAUSE10
XX.XX.XX… Arbitrary bytes (e.g. System Exclusive) F0.

When MIDI is activated in menu Settings, SongBook will connect to all input and output sources on the MIDI bus.

You can select a song with a MIDI command by inserting a directive {midi-index: , ,…} in the song. You can also send certain MIDI commands when opening a song by inserting {midi: ,,…} in the song. You can also use a MIDI pedal to scroll up/down in a song, by entering the respective command in Settings.

The general MIDI command syntax is .:@ (see table below). However, in most cases it is easier to just select the MIDI command from the list of last received commands (via menu in song editor, or for up/down pedal in Settings).

I’m still trying to get the program changes correct. Midi changes are being recognised, as per the pix.
This was a later response from the developer
N is for sending notes (like when you press key on the keyboard), so
definitely wrong. So what do you see in the MIDI menu in the SongBook
editor when you send the MIDI commands from the keyboard?
{midi:PC60, CC1.3}
would first send a program change, and then a control change. Is that
what you had in mind?
Sorry, really hard to help from here with such specific questions.
I did the above as per his advice, still no luck.

I’ve got SongBook changing songs in VST Live now! :smile:

When experimenting with this I believe one must be aware that if a CC0 (MSB )i s sendt and not “terminated” with a CC32 (MSB) it gets very confusing, because sometimes it switches to another song and sometimes not (depending on what signals are sendt from different songs.)

To be absolutely certain that there are no “non-terminated” signals lingering in VST live, restart the program. Be sure not to select a song containing midi messages right before trying your song select in SongBook then this will work:

Create 7 songs in VST Live and let song 5 have at least 4 parts.

In VST Live select for example song two with a mouse click

Then without having sendt any previous midi signals try swithing from a song (preferably one without midi signals for now) to a song that has this:

{midi:CC0.4, CC32.2}

It will select song 5 part 3! :smile: :+1:

MIDI values are zero based whereas you see your songs and parts as one based. This behaviour is normal and you need to subtract one from the value you want.