Is "allow rests within beams and at start and end of beams" global only?

Hi,

I want to begin and/or end some beams with rests. Usually, I don’t want this, but in cases where it improves rhythmic clarity, I do.

I see how to enable this in Notation Options. But I would like to do this on an individual basis. When I set this option back to “Allow rests within beams,” music I’ve entered with the beams beginning/ending with rests now accords with the new option.

Makes sense. But I would expect that using Edit > Notations > Beaming > Beam Together, or some lower zone option, would allow me to override the default, just as I can do when breaking a beam when the “Allow rests within beams and at start and end of beams” option is active (using Edit > Notations > Beaming > Split Beam).

Is there some way to do what I want, or should this post serve as a feature request?

The general behavior should be: set things by default and allow local overrides.

I’m running Dorico 4.2 on macOS.

John

Select the rest and the note. Edit>Beaming>Stemlets>Force Stemlet Beam. Does that work for you?

No, that just seems to add a stemlet to a different rest that is internal to the beam.

Thanks for your suggestion, though.

How many option do you need?
beam1

Yeah, the ones on your top staff with rests at start and/or end of a beam group are the ones I can’t do now, not without activating the global option that does it. And of course that changes many more beams than the ones that I want to have this beams-across-rests behavior, which would mean lots and lots of beam splitting.

My beam options are (I think) pretty much the default ones (eg my default is not to beam over rests). You can override the global settings by selecting the notes you want to beam and applying the appropriate operation in edit>beaming.

Really? This really does not work for me, in 4.2. Is this a regression?

In other words, for me there is no option in the submenu you mention that will beam to a terminal rest, unless that is chosen as the default behavior in Notation Options.

stemlets.dorico (450.0 KB)
Also 4.2. Drag into Library Manager to compare notation options.

The results you get depend on what you had selected when you forced the stemlet beam.

I don’t think you can force a beam without a stemlet without setting the per-flow notation option to allow that. You could try setting that option, then splitting beams where you don’t want the beam to extend? Although I confess I’ve not checked whether that works.

With Allow rests within beams you can achieve @Janus’s results (stemlets over rests) by selecting each group you wish to beam together, then right-clicking > Beaming > Force Stemlet Beam (or achieved here via the Jump bar)
Aug-06-2022 13-20-58

As Lillie said, you can’t force a beam without a stemlet unless that Notation Option is set.

1 Like

Ah, yes, this works for me! Thanks. I must’ve selected the wrong thing before when @Janus suggested this. Sorry, @Janus!

Thanks, everyone!