Is Cubase lousy at crossfades?

A task that I have to perform a lot is making seamless edits of repeated audio clips with long held tones. No matter what settings I use in the crossfade dialog box, no matter what the length and the shape of the fade, I can always hear the fade. I can never get rid of annoying, artificial-sounding changes in volume, phase or timbre.
But if I put the exact same audio clips in Logic, select a fade region and press fade, voilà - excellent quality, always at first try, without any tweaking. Same thing in Pro Tools, I believe.

Is there any remedy for this - I like Cubase best, otherwise, so I wouldn’t want to switch.

One thing to consider is not reaching for the crossfade as your first tool to join two takes.

I find many times I can use the slip function available in the comping suite to get a silent/seamless joining of the two takes. I zoom in almost all the way till I can see a repeating pattern of rises and falls in the audio. I then increase the vertical size of the two lanes I’d like to join, then slip one of them R/L so there is continuity of the repeating pattern of rises/falls across the two segments, preferably not at “zero crossings”.

I’d say 80-90% of the time I do it this way, I get a totally inaudible joining of the two takes, even when solo’d. The times I can’t are almost always times when the tonality of the two takes is actually quite noticeably different.

If I do have to crossfade, I try to make my split at a formant (non-tuned sound like Ssss, Shhhh, Ttt, Ppp, K/G/Ch, etc.).

Otherwise, making the split when it is masked by another sound (snare, etc) can help with a less than perfect crossfade.

When these options are not available, I do often find that using the X-fade is more miss than hit in my hands as well, interesting to read that isn’t so in other DAWS.

Thanks, those are good tips. I specifically need to use crossfades because I make loops of continuous sound to be used in Ableton Live, and the way I do it is that I repeat an audio clip three times, with identical crossfades, and then bounce the middle clip, with the crossfades. This way I get an audio clip that can be looped seamlessly without using the auto fade function in Live. The end of the clip will crossfade correctly to the start as the Xfades are identical.
It may be that I was just lucky when I did the test in Logic. I haven’t used Cubase for that long yet (although I used the early versions a lot in the 90’s) but it does seem to me that it’s particularly tricky to get a decent sounding Xfade in it.