Is "Duplicate" hot spot drag working correctly?

[Edit: This is a thread I started because I am getting different results on my system when I duplicate audio using the “hot-spot-drag” technique vs. when I use the “CLICK-HOLD-ALT-DRAG” technique. I’d appreciate it if someone might have a moment to check out the repro and report what happens on their system. The repro is in the post of February 5, 2017 at 2147 hrs, here: https://www.steinberg.net/forums/viewtopic.php?f=250&t=112072&p=614079#p614079 , farther down. The intervening posts, including this one, can be skipped, as they are just working towards that repro. Thank you!]


I wind up with duplicate audio clips of different time duration in a variable tempo project.

Repro:

  1. Create a project where one bar is at one tempo, and the bar immediately following it is at faster tempo. A larger difference in tempos makes all this easier to see, 20-30 BPM faster for the 2nd bar should be good.
  2. Using a drum VSTi, record one bar of audio in the second bar, I used EZD2 and the Punch In/Out secondary loop controls in the toolbar.
  3. After it is recorded, grab the middle right hot spot and drag right so it is duplicated once.
  4. Select the original audio, and note its time duration in the info line (minutes:seconds).
  5. Select the duplicated audio - it is a shorter time duration than the original.

Troubleshooting: The greater the tempo in the 2nd bar, the shorter time duration the duplicated audio is.

As an internal control, when I duplicate the old-fashioned way (select/hold the original audio, CTRL-ALT click/hold, then drag), the duplicated audio is as expected the same time duration as the original, no matter what the tempo difference between the two bars is.

Anyone else? (I looked at Confirmed bugs and unconfirmed bugs, didn’t see this, sorry if I did miss it …)

Hi,

Could you post a screenshot, please?

How is it placed regarding to the tempo change?

Hi Martin -

Thank you for the reply!

I duplicate it by dragging right, and place it touching the original.

The differences in timing duration I see are in the order of tenths of a second, per the info line.


I don’t know how to do moving picture screen shots, I’m sorry. Were you able to do the repro?

Is the audio clip in Musical Mode?

No, no musical mode.

Remember, it works as expected when I don’t use the hot spot handle to duplicate (i.e., it duplicates accurately when I use the old click/hold + CTRL-ALT drag). I only notice a problem when I duplicate using the “new” way (new to me, since I came from Cubase 7.5.40).

One little thing to check on. Is the ruler in Time Linear or bars and Beats linear mode? Sounds like it’s in bars and beats, therefore the even though the seconds duration is the same, the number of beats is different.

Thanks for reply. The ruler is in minutes: seconds mode. That’s time linear?

As a check for internal consistency: the expected results are seen when duplicating without using the drag “hot spot”, when the ruler display mode remains unchanged.

Is anyone trying the repro? :slight_smile:

I can’t repro here.

The tool I use for screen shots is Greenshot, and for animated gifs, ScreenToGif.

If you try this simplified repro- what happens?

  1. new project, new audio track, new tempo track, ruler set to Time Linear (seconds)
  2. set tempo at bar 1 to 60, set tempo at bar 2 to 240
  3. record one bar of sound.
  4. After it is recorded, grab the middle right hot spot and drag right so it is duplicated once.
  5. Select the original audio, and note its time duration in the info line (minutes:seconds).
  6. Select the duplicated audio - what is it’s length?

BAR 1: 4 seconds

[/img]







BAR 2: 1 seconds





[/img]

Hi SteveInChicago:

  1. Select the duplicated audio - what is it’s length?

It is 1 second long, as seen in the 2nd of the two images, above. The original audio is 4 seconds long as expected.

I also moved it over a bar or two as seen on the right of the images: it is also 1 second long there.

I also ran Cubase in safe mode, and got the same results.


But, the main point I believe is that I’m not getting the same results when I duplicate using the “hot spot drag” technique as I do using the old-fashioned (“click/hold + CTRL-ALT drag”) technique, as shown below. When I use the latter technique (the old-fashioned one), the duration of the duplicated clip is 4 seconds, vs. the duplicated clip being 1 second in duration when the “hot-spot drag” technique is used. (Note: the tempo remains at 240 BPM from the 2nd bar onwards):

[/img]

What I did is to duplicate the first track, then used the old-fashioned “click/hold + CTRL-ALT drag” technique to duplicate the first bar.


1. The question the project shown in this post raises is:
Why do the two duplicating techniques show visually different results, when the same 1st bar of audio was duplicated?


2. The question the project shown in the previous pictures/posts is:
Why does the “hot-spot drag” duplicating technique result in a 1 second duration duplicated audio clip, but the old-fashioned “click/hold + CTRL-ALT drag” technique results in a 4 second duration duplicated audio clip?

It’s maybe something obvious I’m missing? Someone please enlighten me! :slight_smile:

So the refined repro is:

  1. new project, new audio track, new tempo track, ruler set to Time Linear (seconds)

  2. set tempo at bar 1 to 60, set tempo at bar 2 and subsequent to 240

  3. record one bar of sound.

  4. duplicate the track

  5. On the 1st track, grab the middle right hot spot and drag right so it is duplicated once.

  6. On the 2nd track, select click-hold the audio (don’t let go), then before releasing the select click hold CTRL-ALT down. Without releasing any of these, drag right once so it is duplicated.

  7. Compare time durations (minutes:seconds) and visual appearance of the duplicated audio in track 1 vs. track 2.


    Results:

  8. The duplicate in track one (generated using the "hot-spot drag technique) is 1 second in duration. But the duplicate in track two (generated using the old-fashioned click-hold CTRL-ALT drag technique) is 4 seconds in duration.

  9. The two duplicates are visually different as well, apparently correctly corresponding to their different time durations.

It’s as if the old fashioned way of duplicating (click-hold, CTRL-ALT drag) is displayed as if it is “locked” to the tempo at the original audio’s location, and is blind to the tempo at its new position.

The hot-spot drag duplicating technique seems to result in a duplicate that plays and displays based on the tempo of its position, not the source audio’s position.

Have you tried ALT + click and drag, instead of CTRL-ALT + click and drag?

Do you get same results?

As far as I know, holding ALT is enough to copy an event. ALT+SHIFT creates a shared copy. Maybe the CTRL+ALT does something else, not just a copy.

Thanks for the suggestion, misohoza!

I’ll try that when I get back. I’ve been CTRL-ALTing forever, since at least as far back as 6.5, iirc.

It’s funny, because the only time I duplicate audio within a track is to drag it back one bar to give me a count in to the next bar at the end of a ritardando (sp?), where the tempo track reads very slow. In that situation I prefer that it stay the same original length, irrespective of the tempo track value at its new location. So the CTRL-ALT method, where it “stays 4 seconds long” is exactly what I need there. The hot spot drag technique may give me an erroneous count-in to the next bar after the Ritando if its length conforms to the tempo track at the destination (which it appears it does, based on all the above)!
.
.
.
.
.
.
.
EDIT: I tried the ALT-CLICK-DRAG as suggested (actually that just wound up cutting the audio in two, so I did the CLICK-ALT-DRAG). The results were the same as my CLICK-HOLD plus CTRL-ALT-DRAG in that they visually looked the same, and they were both 4 seconds long.

Very interesting though - when I phase-reversed the duplicate generated by CLICK-ALT-DRAG, it did not null with the one generated by CLICK-HOLD plus CTRL-ALT-DRAG.

And, play back of either of those is a bit wonky - first 2/3 of the duplicated audio clip is silent in each.

Something is very weird here.
.
.
.
.
.
.
.
.
Would someone else please try my repro?

So the refined repro is:

\

  1. new project, new audio track, new tempo track, ruler set to Time Linear (seconds)

  2. set tempo at bar 1 to 60, set tempo at bar 2 and subsequent to 240

  3. record one bar of sound.

  4. duplicate the track

  5. On the 1st track, grab the middle right hot spot and drag right so it is duplicated once.

  6. On the 2nd track, select click-hold the audio (don’t let go), then before releasing the select click hold CTRL-ALT down. Without releasing any of these, drag right once so it is duplicated.

  7. Compare time durations (minutes:seconds) and visual appearance of the duplicated audio in track 1 vs. track 2.


    Results:

  8. The duplicate in track one (generated using the "hot-spot drag technique) is 1 second in duration. But the duplicate in track two (generated using the old-fashioned click-hold CTRL-ALT drag technique) is 4 seconds in duration.

  9. The two duplicates are visually different as well, apparently correctly corresponding to their different time durations.

It’s as if the old fashioned way of duplicating (click-hold, CTRL-ALT drag) is displayed as if it is “locked” to the tempo at the original audio’s location, and is blind to the tempo at its new position.

The hot-spot drag duplicating technique seems to result in a duplicate that plays and displays based on the tempo of its position, not the source audio’s position.

EDIT: I tried the ALT-CLICK-DRAG as suggested (actually that just wound up cutting the audio in two, so I did the CLICK-ALT-DRAG). The results were the same as my CLICK-HOLD plus CTRL-ALT-DRAG in that they visually looked the same, and they were both 4 seconds long.

If you press ALT, the select tool will change to scissor tool.

For copying you need to click and hold first ,then press ALT and drag. You can even press the ALT after you started dragging the event.

When I do ALT+click and drag, it just moves the audio, doesn’t copy it.

It definitely does that for me.

Clearly, the modifier keys need to be checked, or there’s some user error happening.

Hello - I’m making this post because I am having different results duplicating audio using the “Hot-spot-drag” technique vs. the “CLICK-CTRL-DRAG” technique. I wouldn’t guess that is “expected function”, and at this point I don’t know if it’s something unique to my machine or not. I have tried this with Cubase Safe Mode as well as regular, with similar results.


If anyone had a moment to try this repro and report their results, I’d be grateful - thanks!


So the refined repro is:

\

  1. new project, new audio track, new tempo track, ruler set to Time Linear (seconds)

  2. set tempo at bar 1 to 60, set tempo at bar 2 and subsequent to 240

  3. record one bar of sound.

  4. duplicate the track

  5. On the 1st track (the original one), grab the middle right hot spot and drag right so it is duplicated once.

  6. On the 2nd track (the duplicated one), select click-hold the audio (don’t let go), then before releasing the select click, hold ALT down. Then, without releasing any of these, drag right once so it is duplicated.

  7. Compare time durations (minutes:seconds) and visual appearance of the duplicated audio in track 1 vs. track 2 (i.e., from steps 5 and 6).


    Results:

  8. The duplicate in track one (generated using the "hot-spot drag technique) is 1 second in duration. But the duplicate in track two (generated using the old-fashioned CLICK-ALT-DRAG technique) is 4 seconds in duration.

  9. The two duplicates are visually different as well, apparently correctly corresponding to their different time durations.

It’s as if the old fashioned way of duplicating (CLICK-ALT-DRAG) is displayed as if it is “locked” to the tempo at the original audio’s location, and is blind to the tempo at its new position.

On the other hand, the hot-spot drag duplicating technique seems to result in a duplicate that plays and displays based on the tempo of its position, not the source audio’s position.




Thanks again to anyone who might have a moment to try this repro! :slight_smile:



To clear up a misunderstanding from earlier in this post (small font because I don’t want to dilute the main issue, which is that different duplicating techniques apparently/possibly yielding different results): CLICK-ALT-DRAG duplicates the audio the same as CLICK-CTRL-ALT-DRAG on my system as far as I can tell. In other words, each duplicated the audio differently than when it was duplicated using the hot-spot drag technique, which is the main point of this thread.

Hi Alexis.

I tried your repro and I get same results as you. That’s if the musical mode is off.

My understanding is that the hot spot duplicating is kind of fixed to bars and beats. Duplicating x number of bars.
Your event is 1 bar long (4 seconds). After the tempo change the duplicated event is still 1 bar but because the tempo is much faster it is only 1 second long. With the musical mode off, the audio is not stretched to fit new tempo, therefore only a part of it is present in the duplicated event.

On the other hand, CTRL ALT drag copies the event as is.

Not sure if it’s a bug or by design, but I get same results as you.

Thanks for taking the time to do the repro, misohoza!

Now that you’ve confirmed the behavior, I’ll know not to use hot spot drag for my purposes.

The hot spot drag not only doesn’t duplicate the entire audio, but sometimes the audio that it does include (as seen visually) is not played back as the cursor moves across it (I noticed that several times while trying to figure this out, it may even be apparent in the repro listed two posts up).

I wonder …

  1. If there a role for hot spot drag duplicating in variable tempo projects …
  2. If setting the audio to musical mode allows the entire audio to be duplicated and play back in those variable tempo projects …
  3. If it is documented somewhere that hot spot duplication can yield different results than ALT-CLICK-DRAG duplication.

Anyway, good to know, thanks again for trying the repro!