is elicenser server down?


I purchased the 10 ->10.5 upgrade, but couldn’t activate.

The error is that elicenser couldn’t contact the server. Internet access/firewall checked ok. I have the latest version installed, I think it looks ok at this end.

Is anyone else seeing this?


Seeing the same thing here. Trying to register a few new licenses for other products and am seeing the same issues.

It seems to be down. Need to try again in a few hours

Confirmed. Having the same issue from my location (Virginia in the USA). I am seeing a 500 internal error that is a TYPO3 CMS originating error page (the software behind the My Products page)… I can see My Profile page just fine, as soon as I click the My Products boom 500 error… I tried in 3 different browsers to make sure it wasn’t related to no liking one of them but no luck. I just filed a support ticket with their team.

i have a same problem

It’s the same on my side. There should be a problem with the server. I don’t know when the official website will be repaired.

Same here… got on the forum to see if it was just me

I tried again this morning (Australia) and it worked ok.

Good here again.

Looks as if it’s down again right now? Can’t update the data base, but other checks are okay (with latest version).