Is it possible to copy Automation?

I’m trying to copy a lane of automation points to another track…

Does anyone know is this possible?

Can’t find anything in the manual and can’t figure out a way to do it…


Select points, copy. Move cursor to new place, Paste.

Ah… just re-read your post. Dinny ken :laughing:

In fact, the easiest method is via the Range Tool (you can even copy the automation to a non-related parameter).

been trying but can’t see how with the range tool…

I select the range of the automation, then copy…

select another track, paste and nothing happens… what am i missing?


Drag ‘n’ drop :wink:

1 Like

I copy and paste all the time.
When you’ve copied the original automation you have to select the automation lane so you have a destination for Cubase to paste to.

There is a Key Command called “Locate Selection” that’s useful for setting the cursor at the right place before pasting.
Then it’s just:

Make Selection
Locate Selection

Cubase seems kind of forgiving for pasting one type of automation into another type lane, at least I haven’t ran into problems with it.

Is there a simple global way of doing this on a blank project? I want to copy CC11 value 80 to the start of every track. I’ve read the manual and this thread, but do I really have to open an automation lane for each track to copy it into? I was thinking about using the logical editor, but it’s greyed out if I select the automation point on track 1.

EDIT - I’m also getting nothing when cutting and pasting this data, even when the right CC lane is showing on the next track. Nothing happens. Also can’t make any sense of drag and drop - just changes the data on the original track.

A couple of points…

  1. If I have read correctly, I’m getting reasonably sure that you have found a bug… Copy/Paste a single automation point doesn’t work, but works o.k. when more than one automation point is selected. (could you please at least try that yourself, to confirm or otherwise? thanks :slight_smile: )

  2. The Logical Editor will only work for MIDI events that are inside MIDI Parts, i.e. not when CC#s are used on automation lanes. But in that latter case, you can use instead the Project Logical Editor.

  3. Drag & Drop: Use the Range tool.

O.K., so none of the above really solves your question (at least, when it is just that single automation event that you want to copy/paste).
One thing I was able to do here, as a workaround, was to add a 2nd automation point (with the same value), then edit its position to be just one tick later than the first automation point. I could then copy/paste them both to other tracks.

Vic, thank you for all that! Yes, you’re absolutely right - I can’t cut and paste a single point, but I can with two so it does sound like a bug. I’ll investigate all your methods later this evening - cut and paste isn’t working well because it moves both points ok but after the 2nd point the value just drops to zero, which is a pain (though I need to experiment more there with automation modes perhaps). Also I have to paste it into an automation lane itself, which is cumbersome.

Have to say, building my template is proving to be a nightmare, what with all my Quick Control woes!

“Also can’t make any sense of drag and drop - just changes the data on the original track.”

Make sure you hold alt when dragging so as to create a copy and not move the original. :wink:

Oh brother, I’m really not having a good introduction to Cubase at all.

You’d think it would be a simple thing - cc11 to a fixed value on all tracks. There appears to be a bug where a single automation point doesn’t cut and paste at all. So ok - make 2 points. Cut and paste… well, first you have to open the automation track individually for each one you’re selecting (all 200 odd in my case). Then paste but - oh dear, after the 2nd point the data resets to zero. I’ve tried setting the automation settings to write-to-end, but that doesn’t seem to make any difference. So that method looks like not working on several scores.

Then I thought "wait a minute, this is so easy - just write enable and record ready all tracks, then waggle the fader I’ve set up to control cc11. Brilliant - except that doesn’t work either. It only seems to record to one single track at a time.

Then there’s the Logical Editor. Now I must admit I am new here, but oh boy that is one fearsome monster. I suddenly feel like I’m a computer programmer from 1979, feeding Fortran into the thing. I’ve looked at the examples, poured over the manual, and so far got precisely nowhere. Just to set a default value.

Apologies for being grumpy. This comes off the back of discovering there is no way to copy Quick Controls between tracks - you have to apply a track template to each individual track, then reset all the midi information that gets overwritten. In short, every element of setting up this template has been a convoluted mess.

I know in the end it WILL be worth it - through the haze I can glimpse a glorious end state, especially with the Avid Artist Mix. But have to say, so far it’s a rocky introduction between us.

Hmm… that, at least, should be working.
I presume you have, in the CC Automation Setup dialog, either the global Record Destination, or at least the Record Destination for CC#11, set to “Automation Track”?
And no Input Transformer set to filter out the CC# data on all but the first track?

Hi Vic, really appreciate your input here. OK, so I’ve changed global CC midi automation to “automation track”. All tracks are write-ready and record enabled. I’ve set write-to-end in the automation window. No input transformers are enabled. And yet it will still only record to one track.

I haven’t found another bug, have I?!

Well, it works o.k. here, so there has to be something else at play. Any chance of uploading a small screenshot, showing the record-enabled, write-enabled tracks? (it isn’t something stupid like a stray solo function somewhere, is it? Are you certain that those other tracks do in fact remain in Record while running?)
Just remind me… you are doing this on new tracks, or tracks that already have something recorded on them? Also, if this is the first automation pass on those tracks, you shouldn’t really need any of the Fill options (in Cubase, it “Fills to end” on first pass anyways)

Thanks Vic, I’ll do the screenshot later. When I record there are big red record parts appearing everywhere. Good news that it’s not happening with you… should be possible, then!

Just realised that I’m still on 6.0.0 - I guess I should install 6.0.2 anyway, but maybe there’s a connection?

I do keep old versions (with their own Preferences Folders), so I just tried in Cubase 6.0.0, and it is fine there too.

The fact that you say you are seeing all tracks turning red, does indeed mean that they are in Record.

I’m a bit stumped at the moment :wink:

Is it always just the first MIDI track that records the automation? (What happens if you change the physical order of the tracks?)

Without actually gong into Record, if you open the appropriate lanes (with the tracks record-enabled and write-enabled), do you see the automation nines move when you move the external fader?

I think I have solved this particular mystery. As ever with me, it’s something unique and peculiar to my oh-so-clever setup!

The problem seems to be a limitation with the EUCON protocol. I’m controlling the midi CCs all via an Avid Artist Mix, which is selected to the Quick Controls, which in turn is mapped to CC11. After a lot more mucking about, it’s clear that it cannot do this to multiple channels at the same time. My slightly inelegant solution for this particular conundrum is to use my keyboard to send midi CC11 (not using the quick controls method) - I can temporarily remap the modwheel to do this.

Thanks Vic for your help in diagnosing, finally got there (sort of) in the end!

EDIT - just as final “go-figure” twist, Cubase initially sort of doesn’t see this automation data when written via the remapped keyboard’s modwheel. No value appears in the Quick Controls expression fader, and “show used automation” reveals nothing. However, when I manually select cc11 to show, the data is there and quick controls suddenly represents it correctly. Once I’ve gone through that for every single channel (groan… again…) it seems to remember afterwards.

Glad that at least there was a logical reason for that :slight_smile:

Oh My GOD!
I’ve regged onto the forum just to thank you
It’s unbelievably awesome!

(To copy alt + drag’N’drop)