is pitch shift broken ?

If I select a portion of 2 tracks with the range selection tool and open Direct offline processing pitch shift it only works once.
I have to close the PS window and open it again to make it work again. I used to be able to keep it open and apply pitch shifts to my hearts content. And the audio gets muted for 5-6 seconds after the shift pitch has completed.
And if I press the audition button it sounds like it’s playing something else :ugeek:
Auto apply is off.
Anyone else with this problem ?
Mads

hmm - no one else has this problem ??

Hi,

It works to me here on both tracks.

I got the same issue for a moment, I dont remember what I did after that but was working again…

hmm - maybe it’s a PC issue ?

I’m glad to hear that I’m not alone on this. It’s very annoying.
If you remember please tell :slight_smile:

I’ve been having a problem with pitch shift for ages. So maybe others are noticing it too. It’s this…
When I open Pitch Shift, I get a dialogue box. Continue/New Version/Cancel. (see attached pic #1)
(1) If I select Continue, the program automatically applies Pitch Shift according to the parameters I set up last time. But I want to set the parameters BEFORE Pitch Shift is applied.
(2) If I select New Version, I get a blank Pitch Shift box, which I can’t do anything with. (see attached pic #2)
(3) If I select Cancel, it cancels, obviously, and I’m back at square one.
Is Pitch Shift supposed to act this way? There seems to be no way I can set the Pitch Shift parameters before Pitch Shift is applied. But that is surely what is needed. Any ideas?
Thanks


Hi,

Is it a selection issue? If you select the event(s) again, can you see the Pitch Shift?

Hello Martin. Not sure what you mean. I don’t see Pitch Shift unless I open it via Audio --> Processes --> Pitch Shift.
If nothing is selected, then I get a blank Pitch Shift screen. But if something is selected before I open Pitch Shift, then I always get the dialog box first, and I have to click Continue to get anywhere. Then PS is applied automatically.

Hi,

The Continue… and other buttons are not related to the time when the process is applied.

Since Cubase 9.5 the process is always applied immediately (I.e. once you open the window).

Continue = the process is applied to all instances of the audio file in the project.
New version = the process is applied only to the selected instances.
Cancel = process is not applied.

Dear Martin
Thanks for your reply. So…
Is it possible to get it so the process is not applied when I open the window, but only when I want it ? And…
I gather there is a way to pitch-shift via the Info Line, but the Algorithm and Transpose options needs to be showing. My Info Line doesn’t have these parameters. (Only Start/End/Length/Offset/Mute/Lock). How can I get them to show, pls?
Btw, I’m running Artist 9.5.

Hi,

Open Direct Offline Process window and disable Auto Apply. Add the Process here.

Actually what you do is the Direct Offline Process in the background too.

Btw, it is applied when you want. It’s applied immediately. You can change the parameters and again it’s immediately applied (to all intended, if you select Continue or to the one only, if you select New). You can remove the process anytime you want to too.

You can’t disable auto apply in Cubase Artist, - you can only do it in Cubase Pro (PDF user manual page 422). And it’s not possible to use the info line for pitch shifting… - sorry :frowning:

Hi,

Sorry, I didn’t know you are on Cubase Artist.