Is there a shortcut for "Move Selection to Cursor"?

In my workflow, I often want to move selected notes to the cursor position (which really means moving the start of the first note in the selection to the cursor position and carrying all of the other notes relative to it).

For example, in the attached screenshot, the cursor is just before measure 82 and I have just performed “select all from cursor to end” (you can see that all of the notes to the right of the cursor are selected).

At that point, I have been moving the mouse pointer to the “Start” area in the upper left and typing in the location of the cursor.

My question is: Is there a shortcut for typing in the location of the cursor? Is there some command/function I could use to move the start of the first selected note (currently at 82.3.3.3) back to the cursor position (of course, taking all of the selected notes with it?

According to the manual selecting “Edit -> Move to -> Cursor” (Ctrl-L) seems like it is what I am looking for but that doesn’t work for me. For reasons I cannot explain, that moves the selected notes back approximately one-half of a tick mark towards the cursor.

Thank you for any help.

Hi,

This is the right way.

Could you describe more your issue? Maybe a screenshot(s)?



Thank you for answering Martin. I am using Cubase Pro 9.5.50 in Windows 10. I have attached two more screenshots. In Screenshot 1, I have just performed “Select all from Cursor to end.” The cursor is at 64.4.3.64. The first note of the selection starts at 66.2.1.73. Then, I did Ctrl-L to move the selection to the Cursor. Screenshot 2 shows the result. The selection has only moved to 66.2.1.10 (from 66.2.1.73).

I have never used quantize or nudge (and, to my knowledge, I have never touched those settings). It seems to me that the “move selection to Cursor” function is only moving the selection by some “nudge” amount on my system. Perhaps I have some incorrect settings. Perhaps it is a bug in the code.

I am grateful for any help.

Hi,

Could you try in Cubase Safe Start Mode [Disable preferences], please?

Hello Martin,

I have now had a chance to start Cubase in Safe Start Mode with Disable preferences and the behavior of Ctrl-L was exactly the same on my system. The selection that I made was at 10.1.1.63 before I clicked on Ctrl-L and that function moved it only back to 10.1.1.0, not all the way back to the cursor.

Hi,

Are there any other data selected? Like a MIDI Controllers or something? How do you select the MIDI Notes, please?

I select the data using the menu item Edit > Select > From cursor to end (for which I have created the key command “”. These are piano scores, so yes, the sustain pedal (cc64) and the “soft” pedal (cc67) data (if there are any) are also selected using that command. I need the pedal data to move with the notes.

Hi,

That’s it. The very first select MIDI event is CC64 or CC67, so this event is moved to the cursor.

Thank you for figuring it out, Martin. Can you think of any shortcut that I can devise (via a macro or whatever) to copy the location of the cursor (as displayed in the transport panel) into the location of the first selected note (as displayed in the “Start” box of Key Editor)? That is what I do manually at this point.

I’m confused on how to adjust the project end point. My song is only 4 minutes long but I have 16 minutes of blank space after my song. How to I get rid of that empty space displayed after my song? I’m using Cubase 10 and it’s not intuitive like 9.5 was with a button to move. Or at least I can’t find it anymore. Help?

Hi,

If the focus is in the Key Editor, you can use Locate Selection Start [L]. So the Macro…?

  • Open Key Editor
  • Navigation > Right (to select the very 1st event in the Key Editor)
  • Locate Selection Start
  • Close Key Editor

I haven’t tried this. Could be a bit risky because of the blind note selection.

Hi,

This is totally different topic. Please don’t hijack existing threads with other topic.

Project > Project Setup [Shift + S] > Project Duration.

Yes that helped. Topic seemed closest on this thread to any other for which I searched, and didn’t find other threads helping until I got here. So thanks, but I’m gonna keep asking questions if that’s ok for us noobs. Kinda thought that was the point of having a forum. Sheesh.

Hi,

Of course you can ask questions. My point was, create a new thread for a new topic, please.