Is there a way to have cues above AND below the staff

I am writing a drum set part and I want to show the drummer a cue above the staff showing the treble players and have a cue below the staff to show the bass figures. Is there a way to do that?

Stan Martin
Dorico 5
Windows 10 pro

Do you mean at the same time or just either/or?

He clearly means that he wants both at the same time.

Perhaps the solution is to give the percussionist a cut down score that has those other two parts assigned for some/all of that layout (ie- the layout is labeled for the percussionist but is really a score with all three player’s parts assigned) and then you could use manual staff visibility to hide the other parts anywhere you don’t want them. You could also assign those spots where the parts are shown to scale differently from the percussion part. Then you have total flexibility.

You can have multiple cues overlapping, you just need to input the second one starting at a later rhythmic position than the first, then move the second back rhythmically.


Since it is in the drum part, I want rhythmic cues. One above the staff and one below. And they do not start at the same time. In the staff, I have a slash region. I can’t seem to get second cue to appear below the staff, even though I use the properties panel and click placement “Below”.

Shh, don’t tell the developers I said this, but very often I find that it’s faster and easier to take a renamed Timpani (no key) instrument and fake the entire drum part with custom noteheads.


Have you tried something like this?

Placement (above/below) refers to the cue label, not to the cue itself.

Also, rhythmic cues can only be placed above the staff. As per Lillie’s post, you can set the distance of the rhythmic cue from the top staff line, but you can’t specify negative values (which would enable a rhythmic cue to to be placed lower than the top staff line).

You can write the bass part in the drum part. It is not connected then so if you change the basspart you have to change the drumpart.

So I would make a cue above the regular way and the set an extra bassdrum on middle c below the system. There you can make the basspart rythm and you draw the slash region. Set properties to make other voices visible and maybe flip the stems of that extra bassdrum.

I did not try it but I think it is possible.

1 Like

I guess it looks like this should go on the “Wish List” of things that we would like to see in future versions.

Haha, I used to do that too! In D5 it’s easy enough to duplicate and modify that to default to an instrument using percussion clef and piano range (so no “out of range” notes) too.

This comes up reasonably often I suppose, but if we’re making wish lists, it’s worth pointing out that Dorico’s cue feature is not usable for drum set writing when both parts and score are required. (It’s fine for a quick arrangement that won’t need a score.) Cues in a drum part are not entrance cues, like those that appear in other instruments. Cues in a drum part literally are the drum part, so it has to appear in both the parts and the score. As cue visibility in a layout is an all-or-nothing affair, I can’t have cues appear in the score without all the entrance cues for all the other instruments appearing too, which no conductor will want to see.

The examples below demonstrate the issue. If I want to see a functional drum part in the score, I have to show ALL cues in the entire score Layout, which is a bunch of clutter the conductor doesn’t want to see, like the Alto Sax part here:

If I turn off Show Cues for that Layout, then I’ve gotten rid of the clutter, but I now have no idea what’s in the drum part:

If the drummer misses a hit, is it because they messed up, or because it’s not in their part? Who knows? I now have to stop rehearsal and ask or go look at their part which is a huge waste of rehearsal time.

It would be nice to be able to use rhythmic cues in drum parts, but as of now there’s not really a good alternative to just manually inputting them. (Additionally, Drum part “cues” are often full-sized noteheads too, and unless I’m mistaken, you can’t change the cue size without a global change in Engraving Options.)

1 Like

It is possible to have some cues showing in the score and others not showing.

  1. In Layout Options > Players > Cues: choose the score layout, enable Show cues and click Apply.

  2. In the score layout: Edit > Select All, Edit > Filter > Cues.

  3. In Properties > Cues: enable Hide.
    This should show the location of each cue with a signpost.

  4. Select the signposts of those cues which you want to show, and disable Hide in Properties > Cues.


Oh, that’s a nice workflow! Thanks!!! There’s no way to then have the cues appear full-size in the Drum part, is there?

I think that Engraving Options > Cues > Design > Cue note scale factor (set the value to 1) might be the way to make cues appear full-size, but it will affect the note size of all cues in all layouts.


It would be nice if the Scale or Custom Scale properties would work with cues so drum part cues could be full-size, but keep the other entrance cues the normal cue size. It still kinda bugs me that there are Properties settings that just don’t work. If they aren’t functional with a specific item, then they get greyed out in most programs to let the user know they aren’t available for that, rather than let the user select it but nothing happens.


As I said way up the thread, there are ways around this. Create two spare instruments, rename them cue top and cue bottom, and assign them only to the percussion part layout in the desired order, and then cue into them where you need cues, and use the manual stave visibility feature to hide it everywhere else.


Thanks, Romanos! Do the two spare instruments need to be percussion instruments? Because they need to be rhythmic cues?

No–Use any instrument that you want (could be a single line instrument if you really want) and then just change the cue type to rhythmic.

1 Like

Hi Romanos,
Do I add two instruments to the percussion player? I added two players and assigned them to the drum set layout. I get three staves on the drum set layout. Not sure what I’m doing wrong.

Are you in galley view? All the instruments a player has will display in this view (rather than page view).