is there a way to make/export a montage so it doesn't add a 2-second pre-gap?

subject says it all…

artist needs files to be an EXACT time and i don’t want to deal with post-removing a pregap at the beginning of the first song each time we go through revisions and such…

it’s getting very frustrating.

if i have audio files in the montage that exactly equal 20 minutes in length… export WAVs, import into itunes (my client likes to make sure the iTunes length is precise) it shows in iTunes as 19:58

when i export a PQ sheet from wavelab it lists the album as 20:00. why is iTunes showing 2 less seconds?

if i add 2 seconds of silence to the beginning of one of the WAV files, thus making the total length of the audio/montage 20:02… it shows up as 20:00 in iTunes, but the PQ sheet shows it as 20:02.

i can’t get the PQ sheet and iTunes to match… and the audio must be 20:00 exact.


Legacy of CDs. The 2 second gap before the first song is an absolute requirement of the audio CD specification (Red Book). The report is designed around CD pressing requirements (PQ is a CD term, after all).

I can see that a way of reporting which omits it when CD is not the target would be useful, though.


I never deal with the pregap myself. I start all songs as I would want them to start in any media player/streaming service or piece of software and when I render a DDP or burn a CD, the 2 second pregap is automatically added.

For example, if the first song has an abrupt downbeat start, that happens at about 200ms on the timeline. Not, 2min and 200ms. The pregap takes care of itself when formats like DDP require it.

My times are all exact with the timeline shown in WaveLab, and that stays the same in any further situations, media players etc.

When you make a PQ report, you can choose to ignore the CD Pregap on the report. See attachment.

Does any of this info help?

With this method, all times are 1:1

when i ignored the CD pregap on the report it actually made it come out to 20:04 ! it added 4 seconds for some reason!?!

anyway, i think the only thing i can do is keep it so my FILES = 20:00 IN ITUNES and even though the report says 20:02 explain to the client that it’s actually 20:00

this is not going to CD. it’s digital-only.

and i’m confused why if my montage markers start at 00:00 and end at 20:00… that iTunes reads the exported wav files as 19:58

see attachment

so to make iTunes read 20:00 i need to actually make my montage/audio 20:02… as in extending the audio files so the length on the montage timeline actually reads 20:02… with the audio starting at 00:00 … why is iTunes subtracting 2 seconds from the exported WAV files?
Screen Shot 2020-04-15 at 12.08.32 PM.png
Screen Shot 2020-04-15 at 12.04.13 PM.png

What happens if you load the rendered WAV files back into WaveLab back to back on a new motange track? If you test this in the same montage (maybe using a Reference Track if you’re on WaveLab 10) it should be clear as to what’s going on.

The rendered WAVs should be 100% in line with the files arranged on your initial montage timeline.

Also, where in iTunes are you seeing a specific time? I just mastered an album that 26:16 and iTunes rounds that up to 27 minutes in two different places. In general, I don’t find iTunes to be a very accurate master approval tool.

if i re-import the WAVs, as you suggested, it comes in at 20 minutes, just like my audio.

see the screenshot… here, you’ll see the audio goes to 20:02, but my end marker is at 20:02. this is because i was playing with extending the audio to get iTunes to read correctly.

the exported WAVs = 20:00, but, iTunes still reads it as 19:58

ok… curious thing… iTunes says “total time” is 19:58, but if you actually do the math and add up the individual track times that iTunes lists it = 20:00

??? so, maybe there isn’t a timing issue but just a weird iTunes issue… i’ll have to explain to the client that its actually 20 minutes, despite iTunes saying it’s 19:58. if seeing 20:00 is that important to him, i’ll have to actually make the audio 20:02 !

Depending on your rendering settings (Whole Montage, CD Tracks, or something else), it’s hard to know what you are really doing but I’d say if your rendered files match what you are doing in your WaveLab montage when you load them back in to test and everything is as you want, then everything is correct and who cares what iTunes says.

iTunes may do some time rounding and is more of consumer app than professional tool. How do the individual song times in iTunes compare?

I’m thinking this is a non issue and I wouldn’t do anything to your files just to make iTunes happy. Analyze the files in an app/DAW that gives you accurate times.

Isn’t iTunes simply ignoring the 2 sec in Red Book standard
that’s why 20:00 minus 2 sec aka 19:58 ?

PG help :slight_smile:

regards S-EH

WAV and mp3 files have nothing to do with a pre-gap. The file lengths are the file lengths. In the context of CD and DDP, the time is before track 1.

With master files for digital distro, the simply have to sound how you want them to sound. Nothing more, nothing less.

yes, as justin says… the WAV files on their own, put into iTunes, has nothing to do with pre-gaps… and, yes, justin, i agree, i trust the audio file length and WL much more than iTunes… it’s just curious to me why iTunes is doing what it’s doing… and my client has mentioned multiple times about it being accurate in iTunes!

i agree it’s a bit of a non-issue… but… clients first! :slight_smile:

well check in the Montage/CD Tab how to change:

“Show Times Relative to Track #1
If this option is activated, the start of track #1 is the timecode reference, excluding any pause before that track.”

“Show Times Relative to CD’s Absolute Zero
If this option is activated, the beginning of the CD, including any pause before track #1, is the timecode reference.”

sorry if I misunderstood the included pre-gap question
I simply mean iTunes was reading a CD Track as an Audio CD
maybe there is a preference setting in iTunes to change this
or simply use an DDP Player or on OSX use XLD!

regards S-EH

Excuse the stupid question but why is your client so obsessed with the length on ITUNES? Just wondering?

I have a few clients (including a label) that insist that tracks end with no milliseconds … so 3:35:00 not 3:35:50

Sometimes, there’s an underlying artistic reason.

I just do what I’m told.