Is there any way to attach a coda sign to an empty measure with hidden rests?

In the example below, I want to hide the rests while keeping the coda sign (and chord symbols) visible.

If I move the chord symbols’ attachment point slightly to the right, the rests hide, which I want.

But the coda sign disappears, which I don’t want.

I can’t move the coda sign attachment point to the right, because the splits the measure in two.

Is there a way to get my desired result?

Thanks!

Dorico Pro 3.5
macOS Big Sur 11.5.1

Dear bobk,
I think moving stuff in Engrave mode is what you really want… If you move objects in Write mode, you’re really changing their musical position, which is probably not what you intend to do. Do you happen to NOT have Engrave mode (because of Dorico SE or Elements)?

@MarcLarcher I’m using Dorico Pro 3.5 for macOS - sorry I forgot to include that. Original post updated.

I DO want/need to change the musical position of the chord symbols. I want the rests in these bars to be hidden, and if the chord symbols are attached to beat 1, the rests won’t hide. So I have to use Write mode to move the chord symbols later (I move them just 1/32 or 1/16th note later in Write mode, then move them back to their original positions in Engrave mode).

Or you can turn off multi-bar rest consolidation in the layout (if I’m right in thinking you said you don’t need multi-bar rests?) to avoid the need to position items rhythmically based on rest appearance.

That said, I’m not sure the coda should move or not appear based on the rhythmic position of the chord symbol. Can you share the project, or a version of it just containing this section?

@Lillie_Harris

Turning off multi-bar rest consolidation resolved the problem. I don’t understand why, but it worked. Doesn’t seem like a very good work-around - what if I had wanted consolidation?

The attached file is a duplicate with the original music obscured. It still has the problem.

BTW, the first time I made a duplicate to upload, the problem went away. I tried going back through the undo history to determine at which step this happened, but couldn’t figure it out - I had replaced the notation quickly and haphazardly.

I started over with a new duplicate and proceeded more slowly, testing at each step of the way to make sure the issue remained.

One more thing:FWIW, this project originated as a MusicXML import from Sibelius.

Test file for coda issue 2021-08-05.dorico (906.9 KB)

Unless I’m missing something, don’t forget that you can hide any rests at any time by selecting the peculiar rest or whole measures and selecting the “remove rests” command.

As for weird things happening on an xml import, I’m not surprised. This is common. Hopefully xml parsing and support will be more robust in D4.

It’s always good practice to “reset position” “reset appearance” and double check clefs and barlines on imports.

This is a prime example of why we’re encouraged not to start new threads on related topics.
@Romanos401, you’ve missed this thread: Rests hidden in score but not in part - which makes it clear that @bobk is working in a part layout and is seemingly insistent on leaving multibar rests consolidated.

2 Likes

@pianoleo Point taken. FWIW, I considered adding this to that other thread, but thought it was different enough to merit its own topic.

In this case, I don’t need consolidation, so disabling it resolved the problem. But I wish I understood how it relates to this issue. It doesn’t make sense to me.

@Romanos401 I didn’t know about trying “reset position” and “reset appearance” on import, so thanks for that.

1 Like

When you have consolidation turned on, empty bars don’t show their real rests, they show multi-bar rests. Yes, the little rectangular blob may look like a regular rest, but it’s actually a multi-bar rest. It may be illuminating to go to Engraving Options > Rests > Multi-bar rests and change the setting so that single-bar multi-bar rests show an H rest and a “1” above. That way you’ll be able to see which (single) bars Dorico’s treating as multi-bar rests.

Text items that are on the downbeat of bars - whether Staff text, System Text, Chord Symbols or Tempo marks - break the multi-bar rests but don’t actually prevent the bar from being treated as a multi-bar rest. This enables Dorico to use different rules for how much space a bar should take up etc.

As soon as you put a text item midway through an otherwise empty bar, that bar is no longer treated as a multi-bar rest and shows its real rests (unless they’ve been removed, in which case the absence of the rest is respected).

If you turn off multi-bar rest consolidation, every bar, whether empty or not, is spaced according to its contents. If it contains a bar rest, it’ll be spaced to account for that bar rest (he said, massively simplifying). If it contains notes, it’ll be spaced to account for those notes and any rests. If it contains literally nothing, because you’ve removed the rest that would otherwise be the only thing in the bar, there is nothing for Dorico to space, so it squishes the bar up.

1 Like

OK, but that’s really confusing! It makes no sense: if a bar is not part of a multi-bar rest, why treat it as such?

I wish Dorico would let us specify a minimum number of bars with rests to be considered multi-bar. (I vaguely recall having a related issue years ago and discovering that Cubase has such a preference.)

Thanks for explaining (again) Leo! I’ll keep reading it until it sinks in…

Yes.

Come to think of it - and yes, this is counter-intuitive - if you add a Chord Symbol Region, that will prevent the Multi-bar rests from consolidating during that passage. You’ll still get the squished up bars unless you put in some System Breaks or use the Casting Off Layout Option, though.

1 Like

Thanks. I just un-did “Ends voice” and disabled “Show bar rests in empty bars” in the problem files mentioned in the other thread, and it worked.