Is this a bug???

Hi to everyone
The way I was working until now(v9.5.0) was with auto monitoring on selected track.
So I have enabeled the “enable record on selected midi track” and “enable record on selected audio track” at Preferences/Editing/Project & mixconsole. Also, at Preferences/Vst, I have set the auto monitoring on “While Record-Enebeled”
After the 9.5.10 update this does not work on midi tracks, (only in audio tracks) So even if I have same settings, Only the rec button goes red. The mon button remain closed and I have to manualy activate it every time.

Is this a Bug or I do something wrong???

Please anyone can try this and give a feedback. I am new on Cubase and cant figure it out by myself.

These attachments shows my settings



Thanks in advance

There’s no monitoring for midi because there’s no signal to monitor.
Monitoring is only for external audio signals… So no it’s not a bug.

Why do you need to manually activate it every time…doesn’t the track already monitor without the button enabled?

As far as I’m aware rec enable will always switch a midi/instrument track to input monitor and you would only need the monitor button if the track is NOT record enabled.

thanks for your reply
I have the rec enabeled and I dont hear any sound. To hear a sound need to activate monitor button

Reinstalation solved the issue. dont know what caused the problem anyway