Issue at every Dorico update

I have a recurring issue whenever there is any sort of update of Dorico.

It tells me to turn on the “Download Assistant”. But then gets caught in some loop where it keeps telling me to authorize it, but does nothing. There’s no button to activate authorization of any sort, just a little window with “Steinberg Download Assistant” and a big red rectangle that says “Sign In”.

Clicking on “Sign In” simply opens a new browser window with “Authorize Steinberg Download Assistant”, but nothing to click, no button, no menu, nada, zip.

I always end up having to go through the laborious task of finding the links to manually download whatever update of Dorico I’m at, then going through the whole process of updating “Library manager”, “Activation manager”, etc… and eventually Dorico itself.

I’ve seen some people point to an issue with a computer clock being off by more than a few seconds, but nothing I do with re-syncing my computer’s clock affects this problem.

Sorry to hear that @Michel_Edward - what browser and version are you using? Do you have any content/ad blockers enabled? (not that I’m saying we have ads on that page)

Hi Ben,
I’m using the latest (as far as I know) version of Firefox, Windows 10.
I’ve deactivated any add-ons/plugins that might interfere.

I WAS able to DL Dorico5 and install it, but there’s some sort of issue here.
I simply can’t figure out what it is.

By going manually to the Steinberg website I was able to DL the correct files to upgrade to Dorico5, then and only then did I get my activation code, and things started working.

now when I start Dorico it tells me that “Groove Agent” is missing, but I don’t see any place to download this item (I don’t even think it’s something I need, since I don’t write drum tracks or anything like that)

As I wrote elsewhere I never could sign-in to SDA with Firefox. I had to momentarily switch to Edge… :roll_eyes:

You’ll see it in the Download Assistant

since I can’t seem to be able to activate the download assistant, that won’t help me, unfortunately.

Groove Agent SE can be downloaded manually here: Groove Agent SE 5 Updates and Downloads | Steinberg

1 Like

Could I ask a favour? I’m still trying to track down why Firefox is unable to launch Steinberg Download Assistant.

Could you open a file explorer window and put %APPDATA%\Mozilla\Firefox\Profiles into the address bar, go into the folder that has “-release” on the end of it. There should be a file called “handlers”. Could you send it to me in a PM?

You should be able to turn off the warning; and it’s not a required component.

Can I suggest that some though be given to alternatives to

app launches browser
browser loads page which pops warning asking if it’s ok to launch an app.
browser launches app

It shouldn’t be necessary to bounce through the browser that way, and seems fragile to me.


there’s a “handlers.json” file, but the forum will not let me send that file format to you.

I don’t see any sort of folder with “-release” on the end (or middle or beginning).

my Firefox says it’s up-to-date, with version 113.0.2

If you zip it, then the forum will take it.

1 Like

well! that’s not very polite!



Just a comment re: Firefox and the SDA. I had no problems using the SDA (and SAM) with Firefox. Of course there may be settings or add-ons to Firefox that make various installations different; I generally keep mine pretty much “vanilla” to keep things simple.

I hope that helps in your investigation.

Quite a lot of thought went into the options for authenticating a desktop application with a web-based identity system. We’re using an industry standard OAuth/OIDC auth flow in order to protect user credentials. Unfortunately, the fragility seems to be in Firefox’s handling of URL protocols, not in the mechanism itself.

1 Like

Should be able to do any auth mechanism like that from within the app itself?

Why does nobody else do this?

There are a ton of things that can prevent one of those steps from working.

Could you briefly set your default browser to something else?

With @Michel_Edward 's generous patient assistance, we managed to find and solve the problem.

The UI for managing the protocol handlers in Firefox is a little broken. You can fix it by telling Firefox to use the system default handler “net-steinberg-sda://” URLs by finding this section in the handlers.json file and ensuring it looks like this:

   "schemes": {
       "net-steinberg-sda": {
             "action": 4

Deleting the file and allowing Firefox to recreate it will also work, but you’ll lose any other protocols that have been registered - which could be annoying.

If it’s a common problem, I might consider writing a little script to fix that file programmatically.


Nice work!