Issue: Copy Audio Events. Paste to wrong position and refuse to snap to bar


I am trying to copy audio events from one track to another one in Cubase 11 pro (Windows 10).

I select the events, press L to move cursor to the beginning of selection, press ctrl+c to copy, select the lane of the second track, and press ctrl+v to paste.

Now the events are pasted one quarter before their original position. Then I try to move them manually. Snap is turned on and set to one bar, yet the copied events refuse to snap to the start of the bar. Even with quantize set to 128, they alwys snap either on 128th before or after the beginning of the bar. It is impossible to get them to the start of the bar. Have tried all kinds of different settings for snap and quantize but the problem persists.

Currently, I cannot find any way to resolve this behavior. I do not want to move them in the right position without snap, because that’s an undesirable workaround regarding further processing.

Have never experienced this before, and other events in the same project do not show this behavior and copying as well as snapping when I move them manually works perfectly. So it is not a general issue in this project.

I also realized that somehow the Snap of the specific events is set to 14.2.x, even though the events start at bar 14. However, manually changing this to 14.1.1 does not resolve the issues. Somehow these events - after copying - just refuse to snap to the beginning of the bar, although this is where the original events are located.

Any ideas…?

The pictures illustrate the problem. First one is before copy and second one is after pasting. As you can see, instead of snapping to 14.1, they are pasted at 13.x, even though the cursor is at 14.1.
Pic 3 illustrates my failed attempts to move them manually…this is the closest I can get to the start of the bar, with quantize set to 128.

Did you try the paste special . To original timecode?
On the Edit Menu - Functions you have some options for pasting events . And on the range too. It will depend on how to make time selections and what mouse tool your using.
My advice would be, select all , CTRL + C and then deselect all in the timeline , click on the track you want it to paste and ALT + V, it will paste on that track but on its original time position.


Read about the Snap Point in the Sample Editor, please. There is also lots of discussions about it here on the forum.