Issue - Cubase Master MIDI Clock & External Synth


I’m having an issue I can’t get my head around and I don’t really know wether the problem lies with Cubase or my Synth.

I created an External Instrument (Prophet Rev2) in Cubase and connected it via USB (also tried via MIDI Cable but still had the same issue). The MIDI communication between Cubase (Master) and the Synth (Slave) seems to be working because when I press play, the midi file transmits the data into the synth and audio goes back into Cubase and comes out of my speakers.
The issue itself arises when I try to play any type of arpeggiated preset. Instead of playing the arpeggio, Cubase automatically triggers the sequencer of the Prophet. Arpeggio turns off and Sequencer turns on. :open_mouth:
I’ve tried every configuration I could think off in Cubase and in the Global settings of the Prophet.

Settings look like this:
Synchronization Setup:
Internal Timecode
MIDI Clock Out: Rev2 [check]
MIDI Clock Follows Project Position [check]
Always Send Start Message [tried both…checked and unchecked]
Send MIDI Clock in Stop Mode [check]

MIDI Thru Active [check]
Reset on Stop [check]
Chase Events:
All but SysEx checked

MIDI Filter
Record and Thru: Only SysEx checked

PROPHET Global Settings:
MIDI Clock Mode: Slave Thru
MIDI Clock Cable: USB
MIDI Param Send & Rcv: CC
MIDI Control: On
MIDI Prog Enable: On
MIDI SysEx Cable: USB
MIDI Out Select: USB
Multi Mode: On
Local Control: On

Is there something I am missing? Any help, tipps, suggestions would be much appreciated!

Thanks in advance and have a great day! :slight_smile:


Hey, I have exactly the same issue. I also tried different configurations and the arpeggiator/sequencer thing wont work in Cubase. Did you find a solution for it yet?

best regards

I too have exactly the same set up with Cubase 8.5 and 9.5 (I prefer 8.5) and a rev2 and the same problem under project synchronization I sent MTC to the midi output named rev2 and midi clock to the midi output named rev2 with all the boxes ticked and the REV2 is set to slave but no joy the sequencer or the arp does not run.

Solution : global : Midi Clock Mode : Slave no S/S (because midi clock start triggers the sequencer of the Rev2).