Issue - Cubase Pro 12.0.7 - MIDI Edit window redraw problem

Since updating to 12.0.7, when working in the MIDI Key editor, Cubase doesn’t redraw changes correctly.

  1. Enter a note - a small bit appears at the start and a scrap appears at the end point. The correct note appears when the mouse flies over it after insertion.

  2. When editing a note length, the change does not appear until the mouse flies over the note afterwards. (Unable to screenshot)

  3. When editing a controller, the change appears as a small section at the edit point but the remainder doesn’t change until you change the controller window or close and reopen the key editor.
    Controller edit

I’ve been redoing and undoing things that aren’t real. It’s quite a problem.


I cannot reproduce this.

Could you try in Cubase Safe Star Mode, please?

I started in safe mode - Disable program preferences. The issue was not occurring.
I worked for about 15 minutes and loaded my key command preset and continued working - no issues.
In about 10 minutes, the issue started occurring once again. I cleared the key commands (Clear All) and loaded one of the factory presets (Standard Cubase Commands) and the issue persisted.
Will try again without loading my key commands…

Tried again with no key commands… everything was fine for a while. But after 20 minutes or so:
I inserted 3 notes and deleted the first one, but the velocity remained.

Here I entered 4 notes and deleted the first 2 and the selection went to the next note (normal) but the deleted motes didn’t disappear although their velocities did.
Deleted notes


Have you had previous Cubase versions installed? If yes, could you try to rename all Cubase versions preferences folders, please?

I had Cubase 11 on the machine. I changed it’s folder name to xCubase 11.
Working for a while now without issue. I’ll keep you informed.
Thank you, Martin.

1 Like