[Issue] Logical Editor doesn't work

Create a midi track with notes of different length.
Try to select or delete… notes using settings for the length with conditions “less” or “bigger” etc. in PPQ.
Even standard preset “delete short notes” doesn’t work.
C6 64bit or 32bit - no matter.

I’m on W7 & I think that my hardware is not a big deal in this case.

Really?
I used a lot Logical Editor on C5.
Let me check later…

BTW, checked C5 on the same PC - no problems! so, it seems we have to wait for fix.

Aloha winter and tanx for the ‘heads up’.
{’-’}

confirmed!

not as before …

Confirmed here too :frowning:

… doesn’t seem to be working correctly when set to “Seconds” either.

+1

Hello,

we will have a look (28133)

Cheers,

Chris

Hello, Chris. Thanks.

Hello,

Yep. Logical Editor isn’t working as expected.

I need it mostly for removing short notes and low velocity notes. Worked very well in C5.
Even trying to coax some cooperation by drawing in notes that easily fit within the parameters of a preset do not work. Delete velocity below ____ worked. Delete short note… did not.

With some of the factory presets, like transposing +/-12, notes have to be selected. If nothing is selected, the LE should effect all events in the MIDI part but it’s not working that way.

The Logical Editor is a critical tool for folks who do mostly. Thank you for looking into this.

Really?? At least, that is working o.k. here. :confused:

Funny thing, the Transpose +/- 12 are working this morning without having to first select notes. :confused:

Delete Note by length is still problematic.

I generally set the Function for Select, then Apply to see how the LE responds if I have any concerns.

Delete Short Notes selects nothing.

Delete notes Bigger or Equal selects all notes no matter what the parameter value is set to. Fer’ instance, if the parameter is set to note length bigger or equal to a note 3 beats in length, the LE will also select sixteenth notes and notes that are measured only in ticks.

Sometimes, the notes disappear from the Key and List editors when attempting to select notes in the LE.
Not to be a wise#@$!!, but it looks like the LE sometimes (but not always) deletes the notes when the Function is set to Select.

I’m very pleased to confirm that the Logical Editor is working as it should.
:mrgreen: