Issue: Number of MIDI input devices is limited to 16 in Dorico

If you have DivisiMate installed, you also have 32 MIDI input devices.
It doesn’t matter if you start Divisimate before you start Dorico or if you don’t start it at all. They are just there.
If you’re lucky, your MIDI keyboard will be listed among the first 16 input devices and it will work.
Otherwise you cannot use your MIDI keyboard.
In my case I have Divisimate port 23, Divisimate port 32, then my midi keyboard, then some Divisimate ports, like 08,09,02, 21, then my expression pedal, then 27,22…and so on listed in apparently random order.
The Divisimate ports are not sorted at all.
However, this also means that I can only use the Divisimate ports that happen to be found in the first 16 available MIDI devices, making it impossible to use some useful Divisimate configurations.
Any ideas how to solve this?
Many Thanks,
Franz
P.S.: Disabling MIDI devices doesn’t help either. Only the first 16 input devices are used, even if they include disabled input devices.

I’m not sure about this, I’m afraid. I’ll ask Ulf what and where this limitation is, since so far as I know Dorico asks the audio engine to enumerate the MIDI devices, and to the best of my knowledge it lists all of the ones that it is told about.

Thank you for your quick response.
I can confirm that this limit exists in Dorico.
If I disable Divisimate’s MIDI devices 13-33 in the Windows device manager, I can also use Divisimate’s presets because they mostly only use the first 12 channels or so.
I can also confirm that I can use all MIDI devices (35+) in Cubase. I didn’t find a restriction.
That limit definitely exists in Dorico.
Would be a big help if it was possible to use more than 16 MIDI input devices in Dorico.

Yes, “in Dorico” doesn’t really mean Dorico itself, as I say. Dorico doesn’t do anything itself with MIDI devices, instead relying on what its audio engine (which is a separate application based on the Cubase audio engine) tells it about them. So the limitation exists somewhere “in Dorico” but it might be the audio engine that we need to change.

1 Like

I understand… Thank you!

Hi
Can you try with this virtual MIDI ports creator: loopMIDI | Tobias Erichsen (tobias-erichsen.de)?
Do you see these ports in Dorico?
On my Windows I can see them (more than 20) without any limitation

Hi, I can see all MIDI input devices in Dorico and also in Windows Device Manager.
The problem, however, is that only the first 16 in the list (counting from the top, as seen in the list in Dorico) are used for MIDI note input by Dorico.
Since you cannot sort the list in Dorico either, it is of no use if, for example, a MIDI input device is added after position 16 in the list. It is then simply ignored by Dorico.
The order of the MIDI input devices seems to be random, and you can’t rearrange them either.
The only solution is to disable the unneeded MIDI input devices in the Windows Device Manager to make sure the required devices show up in the first 16 in the list, or of course a fix in the audio engine, or wherever.
Disabling some Divisimate MIDI input devices works for me. It’s just tedious when you have to activate them all individually when you switch to Cubase.

I will look further into this on Windows tomorrow and see if I can reproduce this using loopMIDI as Yvan suggests. If all of the MIDI input devices are showing up OK in Dorico, but aren’t used if they are activated, then it could well be something that Dorico is doing.

I installed loopMIDI. It appears lower down in the list of MIDI input devices and would therefore not be used by Dorico for note input anyway. Also, you can only send Divisimate’s MIDI output to its so-called ports. Each port is then a quasi-MIDI input device.
Thank you for the effort!
Here are a few pictures of how the list looks in Dorico (all input devices from position 16 are ignored when entering notes via MIDI):
Ports01
Ports02
Ports03
Ports04
Ports05
Ports06
Ports07

Hi, I found this thread:

and the solution there solved my issue.
Go to Preferences > Play , expand Advanced Options at the bottom and disable WinRT Midi .

Now all MIDI devices are used for note input.
I hope it helps others too, and thank you for your help!

But maybe it should be corrected somewhere anyway, if that’s technically possible and makes sense.
Anyway, I’m very happy again with all the great new possibilities in Dorico 4.3 :slightly_smiling_face:

1 Like

Aha, thanks. I’ll check with Ulf and Yvan about this.

1 Like

Hi @Franz_Scharf , you said that it works in Cubase. Do you have there switched WinRT-MIDI on or off?

Hi @Ulf ,
I had to check because I’ve never needed this until now. It was switched off in Cubase. When I turn it on, I also have a similar problem in Cubase. Not all MIDI inputs are used. Only the order of the no longer working MIDI inputs seems to be different.
I never noticed this problem in Cubase because it was never turned on.
Thanks!

Thanks so much for reconfirming. Now we know it is a general problem and where to further look at.

1 Like

I tested it again to be sure. In Cubase, with the WinRT MIDI option enabled, I can only use 8 MIDI devices (see screenshot of my MIDI devices in Cubase below). There are 16 in Dorico that I can use.
That might be too much information, but having worked in my first job as a programmer on and off alongside my work as a musician, I know that you can never have enough information.
I would also like to take this opportunity to say that it is almost beyond my imagination how products like Dorico and Cubase can be kept so bug free. Not to mention the last ‘Generate notes from chord symbols’ feature… amazing. Big respect to the whole team!!

Thanks again for your praise and the additional testing effort, it’s highly appreciated.

1 Like

Our expert developer has confirmed that this appears to be a bug in Windows itself, which we will report to Microsoft.

Thank you very much for the information and all the effort!