Issue setting up delay pedal as a hardware insert

I have cubase 9.5 and a scarlet 6i6 interface. Have a delay pedal I like on guitar. Output 3 of scarlett is going to the INPUT of the pedal, and the output of the pedal is going back into to INPUT 3 of the scarlett.

When I go into audio connections in cubase, I click on EXTERNAL FX, clicked on add, typed in the name Delay and then left everything else as is. Selected Generic low latency ASIO for the audio device, and then the only options I could select from in the device port for the sends and returns were Line out (Scarlett 6i6 USB) 1 Left and
Line in (Scarlett 6i6 USB) 2 Right

The 6i6 has 4 line outputs so I was expecting to be able to select different ones. At any rate it doesn’t work. I try to ping the device for latency and just hear a click as if it’s not passing through the pedal.

How do I get this set up??? I didnt do anything special to within scarlett mixcontrol so maybe a I’ve missed a step

Was able to find the drop down list of inputs by selecting the focusrite driver but I still don’t have it routed right in cubase because I can’t ping the device to get the latency, can anyone who has set this up in cubase already tell me how you routed everything?

Then you should maybe read up on that…?

Maybe too mysterious for you, but in cubase you just define inputs and ouputs, and with your interface´s mix control you make sure the signals get to the necessary hardware in- and outputs.

  1. Setup the external fx with the wanted channels

  2. Connect the fx.

  3. Check your onboard mixer that the channels are good to go. Here you dont want the fx input channel summing to your onboard monitor channel. Else you will get double the signal when it also monitors input from cubase (aka phase) (classic misstake).

  4. When you finaly have sound going. You need to ping the connection for latency. Wich means you won’t get any success if you are trying to ping a wet fx like delay. So here you have to make shure you take off the delay. Else cubase won’t know what to make out of the returning signal (classic misstake).

If you cant get this working.
-You need to make shure your asio driver is ok.
-Check that the ports you are using, are active.
-Cables and signal is correct for the external hardware.
-3. is correct
-4. is correct.

ok SO i spent a half hour on the phone with focusrite and remote desktop software right now getting a rundown on how to operate the insanley complex MIX CONTROL software that came with my interface. Im pretty convinced this half of the equation is properly set up. I cannot PING the device, however, which is concerning me. You mentioned it is a delay and that I have to remove the delay. I tried turning the pedals power off, as well as turning down BLEND and DELAY on the pedal itself to remove any delay, but in either case I cannot ping the device.

on the scarlet I am going from output 3, into the input of pedal, and from output of pedal into input 4 of scarlett.

in audio connections -> external FX I have selected a MONO send return effect. I set the send to line 3, and the return to line 4. Named the device Delay.

I then tried to create a FX CHANNEL in cubase and selected “delay” from external fx. then created the track which brings up the dialog with the ping option. I click ping and nothing happens. Where have I gone wrong? is there some other way to “take off the delay” so I can ping it?? Confused

thank you for help. I get the feeling I’m really close to solving this

UPDATE

the FX channel is working. I put a sample in an audio track and sent it to the FX channel. It’s going through the delay (though seems a tad quieter than I’m used to). So success there. Still cannot ping the device though which is weird

quick noob question but how do i bring up the dialog box with the ping device option again? it’s vanished and i cant bring it up without recreating a new fx track

You bring it up as a plugin or you go in to your external fx setup and right click on the fx, select check user delay. Wont bring up a box, but it will ping the connection.

The ping will sound pritty messy on return to cubase if it comes back as a delay. Cubase is listening for the ping. Not delay ping(s) Thats why you need to kill/bypass the delay. Same if you use some outer space wet reverb or FX with slow attacks.

With outboard fx, there is ofthen issues with getting the compensator dead on. So some manual adjustment might be needed (many fx units have the units in/out latency printed in the manual). So if you cant ping it.
You just do it by ear.
You can also use a click track and record/export a wet signal through the FX. Then you can see on the bar how much you are off and adjust the compensator.

THank you reflection for all your help btw

Unfortunately it still isn’t letting me ping the delay. I know I can use a click and do it manually, but I would really like to figure out this function of cubase. When I hit the ping button, or right click test delay in the external FX window like you suggested, it makes a clik sound, but all the values start at 0 and end at 0. Basically it does nothing. I cannot figure out how to actually ping this device, any suggestions??? Ive tried bypassing the effect, turning down all delay times, and powering off the pedal before pinging. nothing is working

You just plug the output direct to input. Then test it. Now you can see the ping on the returning channel in your interface mixer. What result you get there is your base latency for the sample rate you use.

im sorry but do you mean change the routing in cubase or??? I tried changing the way the pedal is hooked up to the interface but still no luck. can you please give me an example of what you mean

I mean physically connect output to input with a cable on your interface. Test the ping without any fx.
You might run in to issues, if the return level from the fx is too low in volume.
So you might want to crank it a bit.