Issue with Cubase Artist 6


I know I’m having Cubase version from ancient times and I’m planning to update it, but not yet have done that.

Anyway I just ran into an issue. I’m trying to start Cubase Artist 6, but it just quits during the text “Initializing: Cubase Plug-in set” in start up. Yesterday everything worked fine and I haven’t touch my device since the last time used. And since the Cubase won’t even start, I have no idea what to do. I tried to remove the plug in folder if that would help, but nothing happened.

So if someone could help me with this one, I’d appreciate. Or is the only way to re-install the whole software. Or perhaps take a leap and purchase Cubase 11. That would be mind blowing decision.

Thanks for your help!


Weird thing. I was able to start the trial version of Cubase 6 and that was ok. I went to ‘Plug-in information’ and checked the Plug-in paths. The paths I had set up have been removed and only default ones are there. I try to add the one was there before I’m getting a message ‘Registry error. Make sure this product has been installed properly’ and VST bridge freezes.

I don’t know if that gives any hint for anyone what might be the issue, but I’m not able to solve this. I tried to reset the Plug-ins in Cubase 6 Trial and after that started the Cubase Artis but the same error reoccurs.


I would recommend to install Cubase again, as administrator. It’s a simple task.

I’m wondering about the VST Bridge, do you use 32-bit plug-ins in your 64-bit Cubase? Why?

Btw, the CubasePlug-in set is set of build-in plug-ins, not any 3rd party plug-ins.

Thanks mate! I don’t of course have any installation media since my device doesn’t have a DVD drive (Last time a borrowed external drive) so I need to download the .iso file first. But yeah, I need to do that.

The reason for 32 bit plug-ins is that I have used in some tracks some plug-ins that have only 32 bit versions. That is from the time I had 32 bit Windows. Some old ones that could be replaceable but I have thought that it was easier to use VST Bridge.

Anyway I think I finally need to update to newest one since Steinberg doesn’t even promise 6 to work anymore with newer setup.


You are right, Cubase 6 is not supported anymore.

Of course it will be interesting to download Cubase 11 Pro Trial and try to open the project there. But be aware, Cubase 11 doesn’t support 32-bit plug-ins at all. No VST Bridge anymore.

Ok, I didn’t know it doesn’t support anymore 32 bit plug-ins. In a sense it’s good to be forced to newer stuff. :slight_smile:

I tried to re-install few times Cubase but it didn’t help. I have absolutely no idea what happened, but I guess only way is to upgrade since I rather do that than re-install the whole device because that has to be done in some point anyway.

Just downloading Trial of Cubase 11 Pro. Nice to see what happens.

Thanks Martin for the help :slight_smile: