Issue with Cubase Inspector and UR22C

recently I found an issue when I use my UR22C with Cubase 10.5. The UR22C Tab in the inspector disappeared.
Here is one example of what I have before:

Now on the inspector only can I see like this:

Is there something I did wrong? I recently upload to the version 10.5.30 when I saw the missing tab. I reinstalled the version 10.5.20 but I couldn’t find the tab again.

Thank you very much.

Ive recently had this with Pro 11 and my UR22C.
I was going to start a thread but ill join this one.

I did two things, and mine is back.
The first was to disable Control room. That didn’t help as far as i could tell. I then opened the mixer app outside of CB to make sure it was working. When i went back in to CB the UR22C panel was back.
Not sure if either of those helped fix it, but its back now. For how long i dont know.
EDIT: Yep. Turning on Control Room seems to disable the strip. Just tried it 3 times. Each time i saw the strip disappear as soon as i turned CR on.

If I understand, you are saying that the UR-22C tab doesn’t display.

So, in Audio Connections route inputs and outputs in the Inputs and Outputs tab.

No, thats not it.
Ive just figured it out, I had to un tick ‘ Exclusive Device Ports for Monitor Channels’ in Preferences. Then all worked properly again.

Maybe that solved it for you – but I was also addressing @Sebhurblum.

The control room can be on or off, this doesn’t matter. Also, the setting Exclusive Device Ports for Monitor Channels has no effect on this, actually.

The only thing needed for the tab to appear is the routing I detailed above.

Well no, that didn’t work for me. If i set the output to the UR22C then Listen doesnt work using CR. CB complains that that the output is already in use and disables it in CR.
So how is it i tried 3 times to do what you suggested (before you posted) and each time the UR22C part of the Inspector disappeared right in front of my eyes. Ticking the Exclusive box stopped this from happening.
I agree, it doesn’t matter if CR is on or off, but if CR has control of the output then the interface tab disappears. Please show me you CR configuration as well.
I don’t get why you say that feature makes no difference when it clearly did.

I think my post got confusing.
To be clear. Setting the in and out as you suggested disabled the Listen function. CR was still working.
CB complains when i trie to set CR to have control of the outputs, but once it had it the UR22C tab disappeared. Changing back to your settings gave me warnings that the Monitoring in CR would be disabled. Going ahead the UR22C tab came back, and Listen stopped working.
Un ticking ‘Exclusive…’ stopped the warnings and gave me both Listen and the UR22C tab.
What am i missing?

Thank you all for your help. I have been able to solve this doubt I have.

1 Like

I try your idea too. But I get double output sound when I deactivate the “Exclusive Device Ports for Monitor Channel’s”. Do you find the same problem with this?

No, i don’t have any issues like that. I don’t really know too much about CR but its working ok for me.