Issue with Mackie Control and MIDI Track [Solved]

When I have my nanoKontrol assigned as Mackie Control and have a MIDI track record armed (red), I hear the respective notes being played when hitting the transport buttons. When hitting Stop for instance I hear the note A6 being played, which is the default note for Stop in Mackie Protocol. There must be a way to avoid this, right?


The problem is, your nanoKontrol is also part of All MIDI Inputs. You can either select the dedicated MIDI Input on the track, or in the Studio > Studio Setup > MIDI Ports, disable the All MIDI Inputs for your nanoKontrol.

Thanks, I already thought it must be something like this. I followed your instructions and no more notes are being played.
However, the problem is that I want to set up some (or maybe all) of the faders as CC-MIDI for my VSTi and thus probably need the All MIDI Inputs checked later on. Is there some sort of trick? Otherwise, I probably have no choice but to reassign all the Transport buttons of my nanoKontrol to undefined CC numbers.


You cannot use Mackie Control and MIDI CC mode at one HW at the same time anyway. So yes, then you have to mail the transport controls manually by using Generic Remote Device.

Well, initially I was thinking about translating the Mackie Faders (which send Pitch Bend) to CC-MIDI, but now that I finally have figured out how to assign my transport controls using Generic Remote, there really is no need for this anymore - besides the fact that it would not work, as you have pointed out.

So let’s assume I assign all the transport controls to any of the CC# from 102-119 which by default are undefined and my faders I assign to CC# 1 for Modulation, #7 for Volume, #11 for Expression, etc. Do I have to worry about recording some garbage information into the articulation of the record armed MIDI track when pressing any of the CC# 102-119 buttons for my transport controls while recording?


No, the transport controls will be excluded.

Btw, be aware about the known issue of Generic Remote. To make it working even after restart Cubase, you have to Export the settings (like to “save” it). You don’t have to Import afterwords, just Export.