Issue with no swing playback on imported midi notes


I have imported a midi file in Dorico 3.1 and am correcting some items in it with the intend to make choir (SATB) rehearsal playback files.
This arrangement contains some straight (waltz) and swing (4/4) parts.

I noticed that the swing parts are not played back correctly in Dorico and am suspecting that this has to do with the fact that the notes originally came from an imported midi file.

Does this sound familiar to anyone?
Any suggestions on a possible workaround?

Attached is a short example where I manually entered one bar, copied the same one bar from the midi file and entered the “swing” rhythmic feel at the start. If you listen to the playback you hear that the first bar is played in swing, while the second one is played straight. (434 KB)

I suspect that there’s a (probably hidden) time signature information or tempo information that comes from the XML file. Make sure you show the signposts and delete the offending ones :wink:

Unfortunately showing all the signposts did not show anything relevant that I could delete.

However, I did find a workaround: export as musicxml and re-import as musicxml.
This apparently ‘filters out’ the things that caused me issues (had to re-apply the swing/straight rhythm changes, but now the playback is correct)

But it is still weird thing happening.

When you import MIDI there’s an option ‘preserve note positions’ - if that is on, which I think it will be in your case then it will play the project as exactly as it was in the MIDI. You can reset this data in the project - switch to Play Mode, select all and then choose Play > Reset Playback Overrides

Yes Paul, that indeed solved the issue, thank you very much!
I thought I had already tried “Reset Playback Overrides”, but it seems I had not selected any notes so it didn’t do anything at the time.