Issue with old BFD3 path and Cubase X project

Hi Everyone

First I am not at all sure this is a Cubase problem? and am wondering if it is a BFD3 issue, but I will explain and hopefully someone can help


I needed to open a very old project, done in 7.5 from when I had BFD3, and it was in my template. I went to the project and rt clicked and said open in X

When I did this it went thru the load process and then a warning came up, something about the path to BFD3 could not be found, click OK to find it, and Cancel to continue

So I sold BFD3 literally 5 years ago, license, library, all of it. So its not on my system at all. However in VST/Plugins folder it still showed for some reason so I deleted it, and tried again

before I did that though when I hit cancel, it opened the project, but as soon as i clicked anywhere in the session the spinning wheel of death happened and i had to force quite cubase. No hard crash, no log window etc

so then I searched the VST plugin folder, deleted the BFD3 icon, then re scanned my plug in folder. I closed Cubase and re started it and tried again to open the project. This time a different window came up and says exactly

“The Plugin BFD3 could not be found for instrument track BFD3 02”

When I click ok, it freezes now and spinning wheel of death happens and it doesn’t even open the project.

So somehow BFD3, which was legally purchased and installed, then legally sold and deledted years ago is preventing me from getting back into the project. The funny thing is I didn’t even use BFD3 in that project, I used SD2 in it. BFD3 was just part of my old template.

I really would love to get back into this project because a friend and I decided to add some tracks to it to update it. HOwever now I am stuck.

Any help would be greatly appreciated.

thanks much

I am on Cubase 10.0.30 on the latest Mojave on an Imac.

The first message was from BFD. You may have sold it years ago, but the plugin was still installed on your computer. After you deleted the plugin, the second message is from Cubase, telling you that you’re using BFD in the project, but the plugin can’t be found.

Cubase should be able to load the project without the BFD plugin. Any BFD tracks won’t play, but the rest of the project should load. If however, Cubase is failing to load the project, you can try putting the BFD plugin back and when you get the first prompt about not finding the library, just press cancel.

Hi Glenn

Thanks much for the suggestion. I forgot to add that I did do that actually. I had moved it to trash, then got the second error, then i resent it to its plugins folder and got the original again, hit cancel, same thing

now, i let the spinning wheel go for about 5 minutes on both, however it never “crashed” cubase, do you think i should just let it spin longer and hope it resolves?


In that case I’m quite certain the problem has nothing to do with BFD. It couldn’t hurt to let it run for a while longer. You could also try to import the tracks from the .cpr into a new project to try to salvage the individual tracks.

Awesome Glenn, was thinking to, well just import all the wav and midi into a new project

the bummer with that of course is the mix is there already and we were just ading a piano and som BG vocals and for me, i thought I could just tweak those in.

but thats def a work around.

i am going to let it spin for 15 min or so tonight, get a coffee and see. again it never crashes cubase, so i always think, it must be trying to figure it out


Sounds good. Just to be clear, when you import the tracks, all the settings of your mix, including insert plugins, will be imported.

oh, that’s awesome, i didn’t realize that. Just thought it was the raw wav and midi!

this isn’t then as bad as I thought. thanks for all the help!

What if you make a copy of another VSTi which you know functions and name it BFD3.dll (or whatever) and put it where Cubase is looking for your old BFD3. This might let you open the old Project, clear out BFD3 references and save it new.

fyi, Cubase doesn’t use the name of the .dll as the identifier for the plugin. There are 4 character codes embedded in the plugin that are unique to each plugin that are used to identify it. In any case, it sounds like this problem is unrelated to the presence or absence of BFD.

GlennO, I don’t understand this last part? The .cpr file is the whole project file, right? Won’t this duplicate the same problem?

I’m suggesting it as something to try. Maybe it will work. Without knowing what the problem in the .cpr is, it’s impossible to say what will or won’t work.