Issue with text tool (below staff) placement

I am working on a score, from a set of parts. The composer (Grainger) uses what he refers to as Blue-eyed English. Instead of ‘cresc.’ (crescendo), he says ‘louden’, etc.

I am using the text tool currently to achieve this. Right now, in Engraving options, I have text to appear 1/2 space above the staff.


When I add the text, it defaults to ‘above staff’ which is OK, as most of the text I want needs to be above the staff. When I click on the ‘below staff’ option in the properties panel, it is moving the text item below the staff, but it is also colliding with some of the staff lines.
Screen Shot 2018-08-05 at 2.50.17 PM.png
This doesn’t happen consistently, and it seems to occur more when notes go above the normal 5-line staff (ledger lines). Is there a way to prevent this? I do not see options for text below the staff in engraving options.

Robby

I was surprised with the screenshot from Dorico’s Preferences. What language is “THÉME” from? I just hope it’s not french, otherwise there’s a mistake (typo?) that needs to be corrected!

Thanks for pointing out my mistake with the acute rather than grave accent in the graphics, Marc. I’ll fix that.

Robby, the issue with the positioning of the text when below the staff is caused by the fact that Dorico doesn’t generally use the outer lines of the staff for collision avoidance, so if there’s nothing close to the bottom of the staff, items (not only text) can get very close or even collide. This isn’t ideal but it’s how things are at the moment. Having said that, we did find a small bug in the vertical positioning of text (and chord symbols) that meant it could be wrong by 1/2 space, and that will be fixed in the forthcoming update.

Dear Daniel,
I could not think you were responsible for french localization ! My god, you do everything!!! Glad to know it’s going to be fixed, although I was not really serious in my remark (and I fear it could be misunderstood)
Glad to know you still find things to fix in the forthcoming update, I’m looking forward to it !

Believe me, I am not responsible for the French localisation! And that’s a very good thing – it’s been 25 years since I studied French, and that was only to a very basic level. I can remember a few reflexive verbs, but that’s about it…

Robby, what if you went the easy route?
Just use dynamics with a Suffix and Hide intensity marking, like here:
You will get perfectly aligned dynamic text:


Thanks k_b, I’ll give that a try.

Robby

I use those all the time (for sottovoce, cantabile and whatever feels good in that dynamics font !)

I must be doing something completely wrong. This help topic:

says that if I select a text object, there should be a POSITION property. I see no such property, and it doesn’t matter whether I am in WRITE or ENGRAVE mode. It doesn’t matter whether I select in score or parts.

This is system text. Is it not possible to place system text under the staff?

No. There is no position property for System text, because you could want it to apply to a DIFFERENT staff in each layout.

What would be the best practice for getting “Segue” to appear above the top staff in the score, but below the staff in each part?

I guess I can leave it as system text, and then drag it to the right place in every part. Is there a better way?

Could you use a Repeat Marker with custom text, and then set the appropriate Layout Options for such a repeat market to appear under the stave?

Brilliant. That works perfectly. I appropriated the “Fine” marking, which I don’t need in this project. I changed it to have custom text “Segue”. In Layout options, I selected my parts layouts (but not the scores) and did Staves & Systems -> Repeat Markers -> Default Placement for repeat jumps and Fine: to “Below Staff”.

Thanks !