Issue with undoing volume automation

Quite a few times I have, by mistake, drawn a volume automation on a track with no prior volume automation. Unfortunately, undoing volume automation doesn’t move the volume fader back to were it was - also there is no entry in the mix console history. The only way to return to the previous setting is to revert to the saved project, which is far from ideal. It seems like the mix console history is not doing it’s job. :frowning:

EDIT: The issue occurs only when Virgin Territories are enabled.

I’m pretty sure that automation history would be in the project edit>undo. Try using that.

But I do agree that the mixconsole undo function is possessed by something and does not work correctly 100%.

A few topics have posted in the CB9 issues forum…

https://www.steinberg.net/forums/viewtopic.php?f=254&t=108404&p=594783&hilit=undo#p594783
https://www.steinberg.net/forums/viewtopic.php?f=257&t=108151&p=593500&hilit=undo#p593500

Regards :sunglasses:

Thanks, however, as I stated, undo in project edit removes the created automation point, but doesn’t move the fader back to it’s original position. Cubase’s history registers manual fader adjustments (in mix console history), and automation (in project history), but does not register fader position before automation was edited. Undoing automation edit only removes the automation points, but doesn’t revert back the fader’s position.

It’s as if one would turn back time after throwing a ball through a window, thus breaking it, in a way in which the ball moves back to one’s hand, but the glass remains broken. Cubase’s is leaving the glass broken, though the time turned back. :laughing:

edit: the topic under the first link you have provided is regarding the same issue. Thanks again.

Maybe we can ask Superman to reverse the earths rotation to turn back time. :wink:

Seriously though… Weird, I don’t see the issue you list. When I make an automation change, the project undo function returns the automation point to it’s previous position. It will also move the mixconsole fader to it’s previous position only if the project cursor is located in a position relative to the automation point where it would affect the mixconsole fader position.

Regards :sunglasses:

EDIT: Virgin Territories must be enabled.

Try this:

  1. Create an empty project
  2. Create an empty audio track
  3. Check out it’s fader position/volume - should be at 0 db
  4. Reveal the volume automation lane on the track
  5. Using a draw tool (key command - “7”) create an automation point valued -oo (minus infinity) - automation read should get enabled automatically on this track
  6. Press ctrl + Z (undo) - previously created point should be removed
  7. Check out tracks’ fader position - it’s -oo (minus infinity), though it should have gone back to 0.

Conclusion - automation history doesn’t register volume’s initial value

I’ve not tried your test, above, but are you sure you’ve not defined a terminator point?

From the Operations Manual:
"You can define any automation event on the automation curve as the terminator point of this part of the curve. This will automatically delete the line between this event and the next one, creating a gap…

https://steinberg.help/cubase_pro_artist/v9/en/cubase_nuendo/topics/automation/automation_defining_a_terminator_point_t.html?hl=automation%2Cpoint

Thanks for your input. I have only made one automation point, and that’s it. I didn’t edit the"terminator" parameter.
However I inspected this further and it turns out the behaviour I have described occurs only when virgin territories have been enabled - and I have them enabled. When they’re disabled, undoing works as expected.

I’m glad it got sorted out. :slight_smile:

Kind of. :wink: Automation undo is broken with virgin territories enabled. :wink:

Would you by any chance be up for reporting this in the bugs list please?

It is the same issue that is decribed here: https://www.steinberg.net/forums/viewtopic.php?f=254&t=108404
I have provided some info regarding Virgin Territories.